summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-09-26 17:02:03 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-10-21 15:38:31 +0300
commit2b4751cc8f013102255e056498d96cde4029b5c6 (patch)
tree21df5daa2f77c7a081e3c04dfc903d60ecaee100 /dev-libs/modsecurity/modsecurity-3.0.10.ebuild
parentdev-libs/modsecurity: add 3.0.13 (diff)
downloadgentoo-2b4751cc8f013102255e056498d96cde4029b5c6.tar.gz
gentoo-2b4751cc8f013102255e056498d96cde4029b5c6.tar.bz2
gentoo-2b4751cc8f013102255e056498d96cde4029b5c6.zip
dev-libs/modsecurity: drop 3.0.10, 3.0.10-r1
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38784 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/modsecurity/modsecurity-3.0.10.ebuild')
-rw-r--r--dev-libs/modsecurity/modsecurity-3.0.10.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-libs/modsecurity/modsecurity-3.0.10.ebuild b/dev-libs/modsecurity/modsecurity-3.0.10.ebuild
deleted file mode 100644
index 515a441f5f65..000000000000
--- a/dev-libs/modsecurity/modsecurity-3.0.10.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} )
-
-inherit lua-single
-
-MY_P=${PN}-v${PV}
-
-DESCRIPTION="Application firewall and intrusion detection"
-HOMEPAGE="https://github.com/SpiderLabs/ModSecurity"
-SRC_URI="https://github.com/SpiderLabs/ModSecurity/releases/download/v${PV}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv x86"
-IUSE="doc fuzzyhash geoip geoip2 json lmdb lua pcre2"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-RDEPEND="dev-libs/libpcre:=
- dev-libs/libxml2
- net-misc/curl
- fuzzyhash? ( app-crypt/ssdeep )
- geoip? ( dev-libs/geoip )
- geoip2? ( dev-libs/libmaxminddb )
- json? ( dev-libs/yajl )
- lmdb? ( dev-db/lmdb )
- lua? ( ${LUA_DEPS} )
- pcre2? ( dev-libs/libpcre2:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig
- doc? ( app-text/doxygen[dot] )"
-
-DOCS=( AUTHORS CHANGES README.md modsecurity.conf-recommended unicode.mapping )
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_configure() {
- local myconf=(
- $(use_with fuzzyhash ssdeep)
- $(use_with geoip )
- $(use_with geoip2 maxmind)
- $(use_with json yajl)
- $(use_with lmdb)
- $(use_with lua)
- $(use_with pcre2)
- )
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- if use doc; then
- cd doc && doxygen doxygen.cfg || die
- fi
-}
-
-src_install() {
- default
- use doc && dodoc -r doc/html
- find "${ED}" -name '*.la' -delete || die
-}