summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Whitlock <gentoo@mattwhitlock.name>2023-01-06 16:46:06 -0500
committerSam James <sam@gentoo.org>2023-01-07 07:39:32 +0000
commit27d5cdcb811de2855c47d3e18e2ba77c912b0fe2 (patch)
treefd9dfd8e4292aeae6387ac6f9e718c3f2a9ef4fb /dev-libs/libsecp256k1
parentapp-arch/lbzip2: fix compile w/ clang 16 (diff)
downloadgentoo-27d5cdcb811de2855c47d3e18e2ba77c912b0fe2.tar.gz
gentoo-27d5cdcb811de2855c47d3e18e2ba77c912b0fe2.tar.bz2
gentoo-27d5cdcb811de2855c47d3e18e2ba77c912b0fe2.zip
dev-libs/libsecp256k1: trivial/aesthetic touchups
Signed-off-by: Matt Whitlock <gentoo@mattwhitlock.name> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libsecp256k1')
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-0.2.0-r1.ebuild50
1 files changed, 19 insertions, 31 deletions
diff --git a/dev-libs/libsecp256k1/libsecp256k1-0.2.0-r1.ebuild b/dev-libs/libsecp256k1/libsecp256k1-0.2.0-r1.ebuild
index 30b67ab2dd17..6af45ef9aab1 100644
--- a/dev-libs/libsecp256k1/libsecp256k1-0.2.0-r1.ebuild
+++ b/dev-libs/libsecp256k1/libsecp256k1-0.2.0-r1.ebuild
@@ -5,38 +5,30 @@ EAPI=8
inherit autotools
-MY_PN=${PN##lib}
-
+MyPN=secp256k1
DESCRIPTION="Optimized C library for EC operations on curve secp256k1"
HOMEPAGE="https://github.com/bitcoin-core/secp256k1"
-if [[ ${PV} == *_p* ]] ; then
- MY_COMMIT="3967d96bf184519eb98b766af665b4d4b072563e"
- SRC_URI="https://github.com/bitcoin-core/${MyPN}/archive/${COMMITHASH}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/${MY_PN}-${MY_COMMIT}
-else
- SRC_URI="https://github.com/bitcoin-core/secp256k1/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/${MY_PN}-${PV}
-fi
+SRC_URI="https://github.com/bitcoin-core/secp256k1/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
-SLOT="0/1"
+SLOT="0/1" # subslot is "$((_LIB_VERSION_CURRENT-_LIB_VERSION_AGE))" from configure.ac
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+asm ecdh experimental +extrakeys lowmem precompute-ecmult +schnorr +recovery test valgrind"
RESTRICT="!test? ( test )"
+
REQUIRED_USE="
?? ( lowmem precompute-ecmult )
- asm? (
- || ( amd64 arm )
- )
+ asm? ( || ( amd64 arm ) arm? ( experimental ) )
schnorr? ( extrakeys )
"
-
BDEPEND="
virtual/pkgconfig
test? ( dev-libs/openssl )
valgrind? ( dev-util/valgrind )
"
+S="${WORKDIR}/${MyPN}-${PV}"
+
src_prepare() {
default
eautoreconf
@@ -46,37 +38,33 @@ src_prepare() {
}
src_configure() {
- local asm_opt
- if use asm; then
- if use arm; then
- asm_opt=arm
- else
- asm_opt=auto
- fi
- else
- asm_opt=no
- fi
-
local myeconfargs=(
--disable-benchmark
$(use_enable experimental)
$(use_enable test tests)
$(use_enable test exhaustive-tests)
- $(use_enable ecdh module-ecdh)
- $(use_enable extrakeys module-extrakeys)
- --with-asm=${asm_opt}
- $(use_enable recovery module-recovery)
+ $(use_enable {,module-}ecdh)
+ $(use_enable {,module-}extrakeys)
+ $(use_enable {,module-}recovery)
$(use_enable schnorr module-schnorrsig)
$(usev lowmem '--with-ecmult-window=2 --with-ecmult-gen-precision=2')
$(usev precompute-ecmult '--with-ecmult-window=24 --with-ecmult-gen-precision=8')
$(use_with valgrind)
)
+ if use asm; then
+ if use arm; then
+ myeconfargs+=( --with-asm=arm )
+ else
+ myeconfargs+=( --with-asm=auto )
+ fi
+ else
+ myeconfargs+=( --with-asm=no )
+ fi
econf "${myeconfargs[@]}"
}
src_install() {
default
-
find "${ED}" -name '*.la' -delete || die
}