summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-19 17:41:28 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-19 17:41:28 -0400
commit763ff631c309053b9e4b6e54dcbbdb7e5f8fc0f6 (patch)
treeaae5ea6a86e9700a517b8ef399a4282b36ddb6d1 /dev-libs/libsass/libsass-3.4.7.ebuild
parentdev-libs/libsass: stabilize 3.5.5 on amd64 and x86 (diff)
downloadgentoo-763ff631c309053b9e4b6e54dcbbdb7e5f8fc0f6.tar.gz
gentoo-763ff631c309053b9e4b6e54dcbbdb7e5f8fc0f6.tar.bz2
gentoo-763ff631c309053b9e4b6e54dcbbdb7e5f8fc0f6.zip
dev-libs/libsass: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libsass/libsass-3.4.7.ebuild')
-rw-r--r--dev-libs/libsass/libsass-3.4.7.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-libs/libsass/libsass-3.4.7.ebuild b/dev-libs/libsass/libsass-3.4.7.ebuild
deleted file mode 100644
index d9df344ffd20..000000000000
--- a/dev-libs/libsass/libsass-3.4.7.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils ltprune multilib-minimal
-
-if [[ ${PV} = *9999 ]]; then
- EGIT_REPO_URI="https://github.com/sass/libsass.git"
- inherit git-r3
- KEYWORDS=
-else
- SRC_URI="https://github.com/sass/libsass/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86 ~amd64-linux"
-fi
-
-DESCRIPTION="A C/C++ implementation of a Sass CSS compiler"
-HOMEPAGE="https://github.com/sass/libsass"
-LICENSE="MIT"
-SLOT="0/0" # libsass soname
-IUSE="static-libs"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-DOCS=( Readme.md SECURITY.md )
-
-src_prepare() {
- default
-
- if [[ ${PV} != *9999 ]]; then
- [[ -f VERSION ]] || echo "${PV}" > VERSION
- fi
- eautoreconf
-
- # only sane way to deal with various version-related scripts, env variables etc.
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- econf \
- $(use_enable static-libs static) \
- --enable-shared
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files
-}
-
-multilib_src_install_all() {
- einstalldocs
- dodoc -r "${S}/docs"
-}