summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-16 11:36:57 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-16 12:34:21 +0200
commit67c42e74dcd45c7716bc29be6368e512ded7439a (patch)
treeb33289cf31f97e2bea41d216a244127fa03078a7 /dev-libs/libpeas/files
parentmedia-fonts/liberation-fonts: Version bump (v2.1.0) (diff)
downloadgentoo-67c42e74dcd45c7716bc29be6368e512ded7439a.tar.gz
gentoo-67c42e74dcd45c7716bc29be6368e512ded7439a.tar.bz2
gentoo-67c42e74dcd45c7716bc29be6368e512ded7439a.zip
dev-libs/libpeas: fix python:3.8 compatibility
Looks like the addition of 3.8 to libpeas and almost all of its consumers months ago was completely untested; fix it up in straight-to-stable because all of those consumers already have 3.8 in their stable versions PYTHON_COMPAT. Closes: https://bugs.gentoo.org/702810 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/libpeas/files')
-rw-r--r--dev-libs/libpeas/files/1.22.0-py38-support.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libpeas/files/1.22.0-py38-support.patch b/dev-libs/libpeas/files/1.22.0-py38-support.patch
new file mode 100644
index 000000000000..6f4645da61c5
--- /dev/null
+++ b/dev-libs/libpeas/files/1.22.0-py38-support.patch
@@ -0,0 +1,29 @@
+From 3571f4b23abbf5c63e38c82d24a1880fa440499e Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <mart@leio.tech>
+Date: Sat, 15 Feb 2020 23:23:09 +0200
+Subject: [PATCH] Fix python-3.8 compatibility
+
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index bd561e2..d3d0073 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -442,7 +442,11 @@ else
+ found_python3=yes
+ PYTHON3_BIN="$PYTHON"
+ PYTHON3_CFLAGS=`${PYTHON3_CONFIG} --includes`
+- PYTHON3_LIBS=`${PYTHON3_CONFIG} --libs`
++ if $PYTHON3_CONFIG --embed >/dev/null 2>&1; then
++ PYTHON3_LIBS=`${PYTHON3_CONFIG} --libs --embed`
++ else
++ PYTHON3_LIBS=`${PYTHON3_CONFIG} --libs`
++ fi
+ PYTHON3_LDFLAGS=`${PYTHON3_CONFIG} --ldflags`
+ AC_SUBST(PYTHON3_BIN)
+ AC_SUBST(PYTHON3_CFLAGS)
+--
+2.20.1
+