summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-09-16 06:28:15 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-09-16 06:28:15 -0400
commit6d14632e8188758dde7842fdca7bfabbe234856b (patch)
tree1b1daafc99551690e48092c5954dec65f892bd15 /dev-libs/libgpiod/libgpiod-1.1.1.ebuild
parentnet-misc/nextcloud-client: 2.5.0_beta2 bump (diff)
downloadgentoo-6d14632e8188758dde7842fdca7bfabbe234856b.tar.gz
gentoo-6d14632e8188758dde7842fdca7bfabbe234856b.tar.bz2
gentoo-6d14632e8188758dde7842fdca7bfabbe234856b.zip
dev-libs/libgpiod: version bump to 1.1.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libgpiod/libgpiod-1.1.1.ebuild')
-rw-r--r--dev-libs/libgpiod/libgpiod-1.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/libgpiod-1.1.1.ebuild b/dev-libs/libgpiod/libgpiod-1.1.1.ebuild
new file mode 100644
index 000000000000..7cbe28bf2d35
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib multilib-minimal
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/libgpiod-1.1.1.tar.xz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs +tools"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable tools)
+}
+
+multilib_src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -delete || die
+ fi
+ find "${D}" -name '*.la' -delete || die
+}