summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-05 16:26:23 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-05 16:28:53 +0100
commitfcc87f31bd72582f535a513692416c82c1b2546d (patch)
treee27128960e663dfe83fab9cc8ba5a32f21a7d53d /dev-libs/libdnsres
parentnet-irc/quassel: Drop git uri w/ insecure protocol (diff)
downloadgentoo-fcc87f31bd72582f535a513692416c82c1b2546d.tar.gz
gentoo-fcc87f31bd72582f535a513692416c82c1b2546d.tar.bz2
gentoo-fcc87f31bd72582f535a513692416c82c1b2546d.zip
dev-libs/libdnsres: EAPI=7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-libs/libdnsres')
-rw-r--r--dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild b/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild
new file mode 100644
index 000000000000..99fa34502800
--- /dev/null
+++ b/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A non-blocking DNS resolver library"
+HOMEPAGE="https://www.monkey.org/~provos/libdnsres/"
+SRC_URI="https://www.monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+)
+
+src_prepare() {
+ default
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}