summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-11 21:19:59 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-11 21:19:59 +0200
commit94e12aeabfce23de76fc295e93d980498c46d042 (patch)
tree8b346032f26df9e5d9159b8edeae352ecfbfb9d0 /dev-libs/libcroco
parentdev-libs/libcroco: ia64 stable (bug #685254) (diff)
downloadgentoo-94e12aeabfce23de76fc295e93d980498c46d042.tar.gz
gentoo-94e12aeabfce23de76fc295e93d980498c46d042.tar.bz2
gentoo-94e12aeabfce23de76fc295e93d980498c46d042.zip
dev-libs/libcroco: remove old
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/libcroco')
-rw-r--r--dev-libs/libcroco/Manifest1
-rw-r--r--dev-libs/libcroco/files/0.6.12-CVE-2017-7960.patch40
-rw-r--r--dev-libs/libcroco/files/0.6.12-CVE-2017-7961.patch42
-rw-r--r--dev-libs/libcroco/libcroco-0.6.12-r1.ebuild60
4 files changed, 0 insertions, 143 deletions
diff --git a/dev-libs/libcroco/Manifest b/dev-libs/libcroco/Manifest
index 2329c260cf2f..647d3f20e22f 100644
--- a/dev-libs/libcroco/Manifest
+++ b/dev-libs/libcroco/Manifest
@@ -1,2 +1 @@
-DIST libcroco-0.6.12.tar.xz 482028 BLAKE2B d43b73ba21f600ec6d549b867a58db956e081ca8b0787db577062e36487d23cd99b384ca3269421d26aff9825725b262fd6a3e48be73448fe984548ab3eb080b SHA512 af9a171d5ccded255b57f170576e67155f12fa0f61ab3e379e907975f77afc37e82e22772c6019b2897cffc15b2425faf3ccfda92b1a45b23eda2519debabeb6
DIST libcroco-0.6.13.tar.xz 487840 BLAKE2B 511212f1849343d55104cc6d17662cacd524bae098bab12d6db58df41710c8dca2c5beb7a37e42feac6d856934a07feb3d11c55dc74ba055e21066f2bdefb260 SHA512 038a3ac9d160a8cf86a8a88c34367e154ef26ede289c93349332b7bc449a5199b51ea3611cebf3a2416ae23b9e45ecf8f9c6b24ea6d16a5519b796d3c7e272d4
diff --git a/dev-libs/libcroco/files/0.6.12-CVE-2017-7960.patch b/dev-libs/libcroco/files/0.6.12-CVE-2017-7960.patch
deleted file mode 100644
index 50095d50b898..000000000000
--- a/dev-libs/libcroco/files/0.6.12-CVE-2017-7960.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 898e3a8c8c0314d2e6b106809a8e3e93cf9d4394 Mon Sep 17 00:00:00 2001
-From: Ignacio Casal Quinteiro
-Date: Sun, 16 Apr 2017 13:13:43 +0200
-Subject: [PATCH 1/3] input: check end of input before reading a byte
-
-When reading bytes we weren't check that the index wasn't
-out of bound and this could produce an invalid read which
-could deal to a security bug.
----
-leio: Snipped cosmetic chunks
-
-diff --git a/src/cr-input.c b/src/cr-input.c
-index 49000b1..3b63a88 100644
---- a/src/cr-input.c
-+++ b/src/cr-input.c
-@@ -404,6 +404,8 @@ cr_input_get_nb_bytes_left (CRInput const * a_this)
- enum CRStatus
- cr_input_read_byte (CRInput * a_this, guchar * a_byte)
- {
-+ gulong nb_bytes_left = 0;
-+
- g_return_val_if_fail (a_this && PRIVATE (a_this)
- && a_byte, CR_BAD_PARAM_ERROR);
-
-@@ -413,6 +415,12 @@ cr_input_read_byte (CRInput * a_this, guchar * a_byte)
- if (PRIVATE (a_this)->end_of_input == TRUE)
- return CR_END_OF_INPUT_ERROR;
-
-+ nb_bytes_left = cr_input_get_nb_bytes_left (a_this);
-+
-+ if (nb_bytes_left < 1) {
-+ return CR_END_OF_INPUT_ERROR;
-+ }
-+
- *a_byte = PRIVATE (a_this)->in_buf[PRIVATE (a_this)->next_byte_index];
-
- if (PRIVATE (a_this)->nb_bytes -
---
-2.10.1
-
diff --git a/dev-libs/libcroco/files/0.6.12-CVE-2017-7961.patch b/dev-libs/libcroco/files/0.6.12-CVE-2017-7961.patch
deleted file mode 100644
index 65a08f4ebabc..000000000000
--- a/dev-libs/libcroco/files/0.6.12-CVE-2017-7961.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 9ad72875e9f08e4c519ef63d44cdbd94aa9504f7 Mon Sep 17 00:00:00 2001
-From: Ignacio Casal Quinteiro <qignacio@amazon.com>
-Date: Sun, 16 Apr 2017 13:56:09 +0200
-Subject: [PATCH 3/3] tknzr: support only max long rgb values
-
-This fixes a possible out of bound when reading rgbs which
-are longer than the support MAXLONG
----
- src/cr-tknzr.c | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/src/cr-tknzr.c b/src/cr-tknzr.c
-index 1a7cfeb..1548c35 100644
---- a/src/cr-tknzr.c
-+++ b/src/cr-tknzr.c
-@@ -1279,6 +1279,11 @@ cr_tknzr_parse_rgb (CRTknzr * a_this, CRRgb ** a_rgb)
- status = cr_tknzr_parse_num (a_this, &num);
- ENSURE_PARSING_COND ((status == CR_OK) && (num != NULL));
-
-+ if (num->val > G_MAXLONG) {
-+ status = CR_PARSING_ERROR;
-+ goto error;
-+ }
-+
- red = num->val;
- cr_num_destroy (num);
- num = NULL;
-@@ -1298,6 +1303,11 @@ cr_tknzr_parse_rgb (CRTknzr * a_this, CRRgb ** a_rgb)
- status = cr_tknzr_parse_num (a_this, &num);
- ENSURE_PARSING_COND ((status == CR_OK) && (num != NULL));
-
-+ if (num->val > G_MAXLONG) {
-+ status = CR_PARSING_ERROR;
-+ goto error;
-+ }
-+
- PEEK_BYTE (a_this, 1, &next_bytes[0]);
- if (next_bytes[0] == '%') {
- SKIP_CHARS (a_this, 1);
---
-2.10.1
-
diff --git a/dev-libs/libcroco/libcroco-0.6.12-r1.ebuild b/dev-libs/libcroco/libcroco-0.6.12-r1.ebuild
deleted file mode 100644
index 9cea2f4ac750..000000000000
--- a/dev-libs/libcroco/libcroco-0.6.12-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 multilib-minimal
-
-DESCRIPTION="Generic Cascading Style Sheet (CSS) parsing and manipulation toolkit"
-HOMEPAGE="https://git.gnome.org/browse/libcroco/"
-
-LICENSE="LGPL-2"
-SLOT="0.6"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
- >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-util/gtk-doc-am
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-CVE-2017-7960.patch
- "${FILESDIR}"/${PV}-CVE-2017-7961.patch
-)
-
-src_prepare() {
- if ! use test; then
- # don't waste time building tests
- sed 's/^\(SUBDIRS .*\=.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
- || die "sed failed"
- fi
-
- gnome2_src_prepare
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- --disable-static \
- $([[ ${CHOST} == *-darwin* ]] && echo --disable-Bsymbolic)
-
- if multilib_is_native_abi; then
- ln -s "${S}"/docs/reference/html docs/reference/html || die
- fi
-}
-
-multilib_src_install() {
- gnome2_src_install
-}
-
-multilib_src_install_all() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
- einstalldocs
-}