summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-07-07 11:16:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-07-07 12:27:24 +0200
commit1ba982e0ca6431328f2538ba3b90bbe545c9549e (patch)
tree86c8ad5b9f6139a3f3753e110b9c8e93f563cee1 /dev-libs/capnproto/capnproto-0.10.2.ebuild
parentsci-libs/octomap: bump to 1.9.8 (diff)
downloadgentoo-1ba982e0ca6431328f2538ba3b90bbe545c9549e.tar.gz
gentoo-1ba982e0ca6431328f2538ba3b90bbe545c9549e.tar.bz2
gentoo-1ba982e0ca6431328f2538ba3b90bbe545c9549e.zip
dev-libs/capnproto: bump to 0.10.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-libs/capnproto/capnproto-0.10.2.ebuild')
-rw-r--r--dev-libs/capnproto/capnproto-0.10.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/capnproto/capnproto-0.10.2.ebuild b/dev-libs/capnproto/capnproto-0.10.2.ebuild
new file mode 100644
index 000000000000..0a6728f73a19
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.10.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/c++
+
+LICENSE="MIT"
+SLOT="0/091"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ssl test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
+ # append-libs won't work here, cmake doesn't respect it
+ # ... and ldflags gets missed once
+ append-flags -latomic
+ fi
+
+ local mycmakeargs=(
+ -DWITH_OPENSSL=$(usex ssl)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package zlib ZLIB)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}