summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-25 21:08:30 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-25 21:29:06 +0100
commit573e40d18478d4f4189a89b9e700239cb4e5be8b (patch)
tree89d9f5018047e56e1f5e723b13035d59415cdef6 /dev-lang
parentapp-eselect/eselect-python: Remove intermediate masked versions (diff)
downloadgentoo-573e40d18478d4f4189a89b9e700239cb4e5be8b.tar.gz
gentoo-573e40d18478d4f4189a89b9e700239cb4e5be8b.tar.bz2
gentoo-573e40d18478d4f4189a89b9e700239cb4e5be8b.zip
dev-lang/python-exec: Explain configuration upgrade in postinst
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python-exec/python-exec-2.4.2.ebuild23
-rw-r--r--dev-lang/python-exec/python-exec-9999.ebuild23
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-lang/python-exec/python-exec-2.4.2.ebuild b/dev-lang/python-exec/python-exec-2.4.2.ebuild
index 121f31e7587c..93ca528d489e 100644
--- a/dev-lang/python-exec/python-exec-2.4.2.ebuild
+++ b/dev-lang/python-exec/python-exec-2.4.2.ebuild
@@ -103,7 +103,28 @@ pkg_preinst() {
done
if [[ ${old_pythons[@]} ]]; then
- einfo "Keeping the following Python preference: ${old_pythons[*]}"
+ elog "You seem to have just upgraded into the new version of python-exec"
+ elog "that uses python-exec.conf for configuration. The ebuild has attempted"
+ elog "to convert your previous configuration to the new format, resulting"
+ elog "in the following preferences (most preferred version first):"
+ elog
+ for py in "${old_pythons[@]}"; do
+ elog " ${py}"
+ done
+ elog
+ elog "Those interpreters will be preferred when running Python scripts or"
+ elog "calling wrapped Python executables (python, python2, pydoc...)."
+ elog "If none of the preferred interpreters are supported, python-exec will"
+ elog "fall back to the newest supported Python version."
+ elog
+ elog "Please note that due to the ambiguous character of the old settings,"
+ elog "you may want to modify the preference list yourself. In order to do so,"
+ elog "open the following file in your favorite editor:"
+ elog
+ elog " ${EROOT}etc/python-exec/python-exec.conf"
+ elog
+ elog "For more information on the new configuration format, please read"
+ elog "the comment on top of the installed configuration file."
local IFS=$'\n'
echo "${old_pythons[*]}" \
diff --git a/dev-lang/python-exec/python-exec-9999.ebuild b/dev-lang/python-exec/python-exec-9999.ebuild
index b835c894838d..574412546bdd 100644
--- a/dev-lang/python-exec/python-exec-9999.ebuild
+++ b/dev-lang/python-exec/python-exec-9999.ebuild
@@ -118,7 +118,28 @@ pkg_preinst() {
done
if [[ ${old_pythons[@]} ]]; then
- einfo "Keeping the following Python preference: ${old_pythons[*]}"
+ elog "You seem to have just upgraded into the new version of python-exec"
+ elog "that uses python-exec.conf for configuration. The ebuild has attempted"
+ elog "to convert your previous configuration to the new format, resulting"
+ elog "in the following preferences (most preferred version first):"
+ elog
+ for py in "${old_pythons[@]}"; do
+ elog " ${py}"
+ done
+ elog
+ elog "Those interpreters will be preferred when running Python scripts or"
+ elog "calling wrapped Python executables (python, python2, pydoc...)."
+ elog "If none of the preferred interpreters are supported, python-exec will"
+ elog "fall back to the newest supported Python version."
+ elog
+ elog "Please note that due to the ambiguous character of the old settings,"
+ elog "you may want to modify the preference list yourself. In order to do so,"
+ elog "open the following file in your favorite editor:"
+ elog
+ elog " ${EROOT}etc/python-exec/python-exec.conf"
+ elog
+ elog "For more information on the new configuration format, please read"
+ elog "the comment on top of the installed configuration file."
local IFS=$'\n'
echo "${old_pythons[*]}" \