summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-24 10:02:23 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-24 10:07:44 -0700
commit46e142254f2fb8e4bc1af0989a18f37026616d83 (patch)
tree252ca3f1ae964eeb217e1412e3f7f9c7fc35b8a3 /dev-lang/rust
parentdev-python/openapi-schema-validator: Keyword 0.2.3 ppc64, #847160 (diff)
downloadgentoo-46e142254f2fb8e4bc1af0989a18f37026616d83.tar.gz
gentoo-46e142254f2fb8e4bc1af0989a18f37026616d83.tar.bz2
gentoo-46e142254f2fb8e4bc1af0989a18f37026616d83.zip
dev-lang/rust: adjust build reqs
Closes: https://bugs.gentoo.org/845354 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.59.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.60.0.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/rust/rust-1.59.0.ebuild b/dev-lang/rust/rust-1.59.0.ebuild
index e8023bd2721d..b4e6eebe900f 100644
--- a/dev-lang/rust/rust-1.59.0.ebuild
+++ b/dev-lang/rust/rust-1.59.0.ebuild
@@ -191,10 +191,10 @@ bootstrap_rust_version_check() {
}
pre_build_checks() {
- local M=4096
- # multiply requirements by 1.5 if we are doing x86-multilib
+ local M=8192
+ # multiply requirements by 1.3 if we are doing x86-multilib
if use amd64; then
- M=$(( $(usex abi_x86_32 15 10) * ${M} / 10 ))
+ M=$(( $(usex abi_x86_32 13 10) * ${M} / 10 ))
fi
M=$(( $(usex clippy 128 0) + ${M} ))
M=$(( $(usex miri 128 0) + ${M} ))
diff --git a/dev-lang/rust/rust-1.60.0.ebuild b/dev-lang/rust/rust-1.60.0.ebuild
index 52373f38bea0..f7e83c6bd47c 100644
--- a/dev-lang/rust/rust-1.60.0.ebuild
+++ b/dev-lang/rust/rust-1.60.0.ebuild
@@ -189,10 +189,10 @@ bootstrap_rust_version_check() {
}
pre_build_checks() {
- local M=4096
- # multiply requirements by 1.5 if we are doing x86-multilib
+ local M=8192
+ # multiply requirements by 1.3 if we are doing x86-multilib
if use amd64; then
- M=$(( $(usex abi_x86_32 15 10) * ${M} / 10 ))
+ M=$(( $(usex abi_x86_32 13 10) * ${M} / 10 ))
fi
M=$(( $(usex clippy 128 0) + ${M} ))
M=$(( $(usex miri 128 0) + ${M} ))