summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-01-28 23:18:17 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-01-28 23:51:04 -0800
commit39d86635d09277959d3cd51ab50664957a319911 (patch)
treed3d90bfb6bc8e7ec35d5cae8792d8ba467a40f04 /dev-lang/rust-bin/rust-bin-1.37.0.ebuild
parentrust-toolchain.eclass: add basic musl support on amd64 (diff)
downloadgentoo-39d86635d09277959d3cd51ab50664957a319911.tar.gz
gentoo-39d86635d09277959d3cd51ab50664957a319911.tar.bz2
gentoo-39d86635d09277959d3cd51ab50664957a319911.zip
dev-lang/rust-bin: add basic musl support on amd64
using upstream tarball Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust-bin/rust-bin-1.37.0.ebuild')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.37.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.37.0.ebuild b/dev-lang/rust-bin/rust-bin-1.37.0.ebuild
index 960639b6f749..b0b8d64de826 100644
--- a/dev-lang/rust-bin/rust-bin-1.37.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.37.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -151,6 +151,15 @@ pkg_postinst() {
if has_version app-editors/gvim || has_version app-editors/vim; then
elog "install app-vim/rust-vim to get vim support for rust."
fi
+
+ if use elibc_musl; then
+ ewarn "${PN} on *-musl targets is configured with crt-static"
+ ewarn ""
+ ewarn "you will need to set RUSTFLAGS=\"-C target-feature=-crt-static\" in make.conf"
+ ewarn "to use it with portage, otherwise you may see failures like"
+ ewarn "error: cannot produce proc-macro for serde_derive v1.0.98 as the target "
+ ewarn "x86_64-unknown-linux-musl does not support these crate types"
+ fi
}
pkg_postrm() {