summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/julia/julia-0.2.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/julia/julia-0.2.0.ebuild')
-rw-r--r--dev-lang/julia/julia-0.2.0.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-lang/julia/julia-0.2.0.ebuild b/dev-lang/julia/julia-0.2.0.ebuild
new file mode 100644
index 000000000000..11b0f7bfa7b3
--- /dev/null
+++ b/dev-lang/julia/julia-0.2.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="High-level, high-performance dynamic programming language for technical computing"
+
+HOMEPAGE="http://julialang.org/"
+
+# uses gfortran in some places, dependencies don't reflect that yet
+
+# tarball remade because upstream lacks submodules, so it's not able to build
+# soo ... they bundle a split out part of v8 that has no build system that makes sense
+# double-conversion nailed in to make build system happy
+# dSFMT is not meant to be packaged
+SRC_URI="http://gentooexperimental.org/~patrick/${P}.tar.bz2
+ http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT/dSFMT-src-2.2.tar.gz -> dsfmt-2.2.tar.gz
+ http://double-conversion.googlecode.com/files/double-conversion-1.1.1.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+S="${WORKDIR}"
+
+# Avoid fragile duplication - see compile and install phases
+JULIAMAKEARGS="QUIET_MAKE= USE_SYSTEM_LLVM=1 USE_SYSTEM_READLINE=1 USE_SYSTEM_PCRE=1 USE_SYSTEM_LIBM=1 \
+ USE_SYSTEM_GMP=1 USE_SYSTEM_LIBUNWIND=1 USE_SYSTEM_PATCHELF=1 USE_SYSTEM_FFTW=1 USE_SYSTEM_ZLIB=1 \
+ USE_SYSTEM_MPFR=1 USE_SYSTEM_SUITESPARSE=1 USE_SYSTEM_ARPACK=1 USE_SYSTEM_BLAS=1 USE_SYSTEM_LAPACK=1 \
+ LLVM_CONFIG=/usr/bin/llvm-config"
+
+# scons is a dep of double-conversion
+DEPEND="
+ =sys-devel/llvm-3.3*
+ dev-lang/perl
+ sys-libs/readline
+ dev-libs/libpcre
+ dev-util/scons
+ dev-libs/gmp
+ sys-libs/libunwind
+ dev-util/patchelf
+ sci-libs/fftw
+ sys-libs/zlib
+ dev-libs/mpfr
+ sci-libs/suitesparse
+ sci-libs/arpack
+ virtual/lapack
+ virtual/blas
+ "
+RDEPEND="sys-libs/readline"
+
+src_prepare() {
+ #uurgh, no fetching in ebuild
+ sed -i -e 's~$(JLDOWNLOAD)~/bin/true~' deps/Makefile || die "Oopsie"
+ sed -i -e 's~git submodule~/bin/true~g' deps/Makefile || die "Ooopsie"
+ # and we need to build stuff, so ... let's just copy around and pray!
+ mkdir -p deps/random
+ cp "${DISTDIR}/dsfmt-2.2.tar.gz" deps/random/
+ cp "${DISTDIR}/double-conversion-1.1.1.tar.gz" deps/
+ # Some cleanups to avoid an OpenBlas dep, and remove some useless git errors
+ sed -e "s|-lblas|$($(tc-getPKG_CONFIG) --libs blas)|" Make.inc || die
+ sed -e 's/$(shell git rev-parse --short=10 HEAD)/v0.2.0/' Make.inc || die
+}
+
+src_compile() {
+ emake $JULIAMAKEARGS || die
+ # makefile weirdness - avoid compile in src_install
+ emake $JULIAMAKEARGS debug || die
+}
+
+src_install() {
+ # config goes to /usr/etc/ - should be fixed
+ emake $JULIAMAKEARGS PREFIX="${D}/usr" install || die
+}