summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-02 18:28:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-02 18:28:00 -0800
commite5954fe2888e24189e79695d6ee819b926ec2c60 (patch)
tree1ba3324289404ee06cb6e65135fadaf68e98e270 /dev-lang/jsonnet
parentdev-python/pytest-rerunfailures-8.0: Version bump, add py38 (diff)
downloadgentoo-e5954fe2888e24189e79695d6ee819b926ec2c60.tar.gz
gentoo-e5954fe2888e24189e79695d6ee819b926ec2c60.tar.bz2
gentoo-e5954fe2888e24189e79695d6ee819b926ec2c60.zip
dev-lang/jsonnet-0.14.0-r1: Revbump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-lang/jsonnet')
-rw-r--r--dev-lang/jsonnet/jsonnet-0.14.0-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.14.0-r1.ebuild b/dev-lang/jsonnet/jsonnet-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..ea949946fb6a
--- /dev/null
+++ b/dev-lang/jsonnet/jsonnet-0.14.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_6 python3_{7,8} )
+
+inherit toolchain-funcs flag-o-matic distutils-r1
+
+DESCRIPTION="A data templating language for app and tool developers "
+HOMEPAGE="https://jsonnet.org/"
+SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="custom-optimization python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+BDEPEND="python? ( ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/jsonnet-0.14.0-makefile.patch"
+ "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+)
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ default
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ use custom-optimization || replace-flags '-O*' -O3
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ jsonnet \
+ libjsonnet.so \
+ libjsonnet++.so
+
+ use python && distutils-r1_src_compile
+}
+
+src_test() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
+ use python && distutils-r1_src_test
+}
+
+src_install() {
+ dolib.so libjsonnet*.so
+ dobin jsonnet
+
+ use python && distutils-r1_src_install
+}