summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-06-15 14:35:17 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-06-20 08:49:24 +0200
commit5917335f381a9064224fd378eeecee5a898b12fd (patch)
treec47287176400fb75d3180ce402127685f5144bd8 /dev-java/saslprep
parentdev-java/stringprep: new package, add 1.1 (diff)
downloadgentoo-5917335f381a9064224fd378eeecee5a898b12fd.tar.gz
gentoo-5917335f381a9064224fd378eeecee5a898b12fd.tar.bz2
gentoo-5917335f381a9064224fd378eeecee5a898b12fd.zip
dev-java/saslprep: new package, add 1.1
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/saslprep')
-rw-r--r--dev-java/saslprep/Manifest1
-rw-r--r--dev-java/saslprep/metadata.xml7
-rw-r--r--dev-java/saslprep/saslprep-1.1.ebuild23
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/saslprep/Manifest b/dev-java/saslprep/Manifest
new file mode 100644
index 000000000000..10350c43db2b
--- /dev/null
+++ b/dev-java/saslprep/Manifest
@@ -0,0 +1 @@
+DIST saslprep-1.1-sources.jar 3735 BLAKE2B 4a2058856f0fa01a6f8ef05ca930d875825653f34c3d2b0bb81d658cb363fc5d4268a212d14e23ce60c666a1482de78e13483605c39783c81a971b148055464c SHA512 63badd75f5444af0077629dcf3f95a7c39d3e12f159a50748f54c36d2aa2cef90887c099d0c89007796174d48da0d25cc93db8ccf07660a8803e3edbbb92da05
diff --git a/dev-java/saslprep/metadata.xml b/dev-java/saslprep/metadata.xml
new file mode 100644
index 000000000000..75321cfb5598
--- /dev/null
+++ b/dev-java/saslprep/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-java/saslprep/saslprep-1.1.ebuild b/dev-java/saslprep/saslprep-1.1.ebuild
new file mode 100644
index 000000000000..c39194d7d0fe
--- /dev/null
+++ b/dev-java/saslprep/saslprep-1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.ongres.stringprep:saslprep:1.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="SASLprep: Stringprep Profile for User Names and Passwords"
+HOMEPAGE="https://gitlab.com/ongresinc/stringprep"
+SRC_URI="https://repo1.maven.org/maven2/com/ongres/stringprep/saslprep/${PV}/saslprep-${PV}-sources.jar"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*
+ dev-java/stringprep:0"
+RDEPEND=">=virtual/jre-1.8:*"
+
+JAVA_CLASSPATH_EXTRA="stringprep"