summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-03-26 19:25:04 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-03-26 19:27:55 +0000
commit2cb1e92f5583bbaafd20824c040dfb9659be75fe (patch)
treef8278605f21fe4bc40bdbd3265cf43edb84ade24 /dev-haskell/wx/wx-0.90.ebuild
parentnet-im/qtox: installs .png icons wrt bug #578210 (diff)
downloadgentoo-2cb1e92f5583bbaafd20824c040dfb9659be75fe.tar.gz
gentoo-2cb1e92f5583bbaafd20824c040dfb9659be75fe.tar.bz2
gentoo-2cb1e92f5583bbaafd20824c040dfb9659be75fe.zip
dev-haskell/wxhaskell: rename to dev-haskell/wx
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/wx/wx-0.90.ebuild')
-rw-r--r--dev-haskell/wx/wx-0.90.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/wx/wx-0.90.ebuild b/dev-haskell/wx/wx-0.90.ebuild
new file mode 100644
index 000000000000..bfcb4c848917
--- /dev/null
+++ b/dev-haskell/wx/wx-0.90.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.9"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN=wx
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="wxHaskell is a portable and native GUI library for Haskell"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxcore-0.90:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"