summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 11:36:15 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 08:59:47 +0100
commitde195e3ce57b76d03cc597137c73219984d06a01 (patch)
treec64a336463a31e6046aa762903ffd3e7d4e8dff1 /dev-haskell/scientific/scientific-0.3.6.2.ebuild
parentdev-haskell/integer-logarithms: add package (diff)
downloadgentoo-de195e3ce57b76d03cc597137c73219984d06a01.tar.gz
gentoo-de195e3ce57b76d03cc597137c73219984d06a01.tar.bz2
gentoo-de195e3ce57b76d03cc597137c73219984d06a01.zip
dev-haskell/scientific: bump up to 0.3.6.2
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/scientific/scientific-0.3.6.2.ebuild')
-rw-r--r--dev-haskell/scientific/scientific-0.3.6.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/scientific/scientific-0.3.6.2.ebuild b/dev-haskell/scientific/scientific-0.3.6.2.ebuild
new file mode 100644
index 000000000000..a65f4fad1a1a
--- /dev/null
+++ b/dev-haskell/scientific/scientific-0.3.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.6.9999
+#hackport: flags: -integer-simple
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # disable test-suite: circular depends
+inherit haskell-cabal
+
+DESCRIPTION="Numbers represented using scientific notation"
+HOMEPAGE="https://github.com/basvandijk/scientific"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # circular depends
+
+RDEPEND=">=dev-haskell/bytestring-builder-0.10.4:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
+ >=dev-haskell/hashable-1.1.2:=[profile?]
+ >=dev-haskell/integer-logarithms-1:=[profile?]
+ >=dev-haskell/primitive-0.1:=[profile?]
+ >=dev-haskell/text-0.8:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flags=-integer-simple
+}