summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-22 15:41:06 -0400
committerSam James <sam@gentoo.org>2022-07-22 23:07:41 +0000
commit10c860bf23ad6ac05adbd0e29a18e8130170476d (patch)
treed1e41a344b1aac227131a1cd1b2c8fb907466f06 /dev-haskell/http-conduit/http-conduit-2.3.8.ebuild
parentdev-haskell/warp-tls: keyword 3.2.12 for ~ppc64 (diff)
downloadgentoo-10c860bf23ad6ac05adbd0e29a18e8130170476d.tar.gz
gentoo-10c860bf23ad6ac05adbd0e29a18e8130170476d.tar.bz2
gentoo-10c860bf23ad6ac05adbd0e29a18e8130170476d.zip
dev-haskell/http-conduit: add 2.3.8, drop 2.3.7.3
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/http-conduit/http-conduit-2.3.8.ebuild')
-rw-r--r--dev-haskell/http-conduit/http-conduit-2.3.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/http-conduit/http-conduit-2.3.8.ebuild b/dev-haskell/http-conduit/http-conduit-2.3.8.ebuild
new file mode 100644
index 000000000000..25b7482e4d22
--- /dev/null
+++ b/dev-haskell/http-conduit/http-conduit-2.3.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +aeson
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # needs a port
+inherit haskell-cabal
+
+DESCRIPTION="HTTP client package with conduit interface and HTTPS support"
+HOMEPAGE="https://www.yesodweb.com/book/https-conduit"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs network
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/conduit-1.2:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?]
+ >=dev-haskell/http-client-0.5.13:=[profile?] <dev-haskell/http-client-0.8:=[profile?]
+ >=dev-haskell/http-client-tls-0.3:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ >=dev-haskell/aeson-0.8:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=+aeson
+}