summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-03-24 10:06:36 +0000
committerSam James <sam@gentoo.org>2024-03-25 11:24:36 +0000
commit0db2e9bd2cb66e21caa902f84d6aceaa966b3bff (patch)
tree0d04fa8b2505def1d94726f532c30c3fc3d668f5 /dev-games
parentmedia-libs/quarter: Stabilize 1.2.1 x86, #926343 (diff)
downloadgentoo-0db2e9bd2cb66e21caa902f84d6aceaa966b3bff.tar.gz
gentoo-0db2e9bd2cb66e21caa902f84d6aceaa966b3bff.tar.bz2
gentoo-0db2e9bd2cb66e21caa902f84d6aceaa966b3bff.zip
dev-games/mygui: remove -Werror
Closes: https://bugs.gentoo.org/927670 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/35898 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/mygui/files/mygui-3.4.3-werror.patch12
-rw-r--r--dev-games/mygui/mygui-3.4.3.ebuild1
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-games/mygui/files/mygui-3.4.3-werror.patch b/dev-games/mygui/files/mygui-3.4.3-werror.patch
new file mode 100644
index 000000000000..d001c9e48baf
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.4.3-werror.patch
@@ -0,0 +1,12 @@
+Remove -Werror
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -174,7 +174,6 @@ include(Dependencies)
+
+ # Set compiler specific build flags
+ if (CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "Intel")
+- add_compile_options(-Werror)
+ if (NOT MYGUI_HIGH_LEVEL_WARNINGS)
+ add_compile_options(-w)
+ else ()
diff --git a/dev-games/mygui/mygui-3.4.3.ebuild b/dev-games/mygui/mygui-3.4.3.ebuild
index 7cc3e5985523..b8690f9d6bc9 100644
--- a/dev-games/mygui/mygui-3.4.3.ebuild
+++ b/dev-games/mygui/mygui-3.4.3.ebuild
@@ -42,6 +42,7 @@ STATIC_BUILD=${WORKDIR}/${P}_build_static
PATCHES=(
"${FILESDIR}"/mygui-3.4.1-build.patch
"${FILESDIR}"/mygui-3.4.1-FHS.patch
+ "${FILESDIR}"/mygui-3.4.3-werror.patch
)
pkg_setup() {