summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2016-08-29 21:00:52 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2016-08-29 21:00:52 +0100
commitd261864f57cbbfad9cf26686897055e27d1ab984 (patch)
tree2fcbdd3ba4bb9b09a82d776bd18eea7d8056be85 /dev-erlang/fast_tls/fast_tls-1.0.6.ebuild
parentdev-erlang/cache_tab: Bump version to 1.0.3 (diff)
downloadgentoo-d261864f57cbbfad9cf26686897055e27d1ab984.tar.gz
gentoo-d261864f57cbbfad9cf26686897055e27d1ab984.tar.bz2
gentoo-d261864f57cbbfad9cf26686897055e27d1ab984.zip
dev-erlang/fast_tls: Bump version to 1.0.6
Support both openssl and libressl. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-erlang/fast_tls/fast_tls-1.0.6.ebuild')
-rw-r--r--dev-erlang/fast_tls/fast_tls-1.0.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-erlang/fast_tls/fast_tls-1.0.6.ebuild b/dev-erlang/fast_tls/fast_tls-1.0.6.ebuild
new file mode 100644
index 000000000000..822a641a030d
--- /dev/null
+++ b/dev-erlang/fast_tls/fast_tls-1.0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="TLS/SSL native driver for Erlang and Elixir"
+HOMEPAGE="https://github.com/processone/fast_tls"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND=">=dev-erlang/p1_utils-1.0.4
+ >=dev-lang/erlang-17.1
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )