summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-12-27 20:22:11 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-12-27 20:22:29 +0100
commit672c0ab589890c9987315710163369c0c347f199 (patch)
tree570594627e57537d8315f12d9a1d9b1b9fce942c /dev-db
parentdev-ruby/minispec-metadata: enable ruby33 (diff)
downloadgentoo-672c0ab589890c9987315710163369c0c347f199.tar.gz
gentoo-672c0ab589890c9987315710163369c0c347f199.tar.bz2
gentoo-672c0ab589890c9987315710163369c0c347f199.zip
dev-db/phppgadmin: add 7.14.7
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phppgadmin/Manifest1
-rw-r--r--dev-db/phppgadmin/phppgadmin-7.14.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/phppgadmin/Manifest b/dev-db/phppgadmin/Manifest
index ed40a199d3ec..69edf6186112 100644
--- a/dev-db/phppgadmin/Manifest
+++ b/dev-db/phppgadmin/Manifest
@@ -1 +1,2 @@
DIST phppgadmin-7.14.5.tar.gz 1153991 BLAKE2B 52f52e02305814a149cdde7498bdffe281c78198241c436182bdebce7e2597aea8ac1e0ae04900073355dbe4da7f41f0f0b83c5ec28a5b476ce6f3249dfff6b7 SHA512 1983b7d98623def3aa0d83f7ea507026abe1699dba3104fddf743fb581a4f1226be8d784990984ebcc22e92c2bed3cacfbec13ed7387d7b87b2662fc66fe0ac6
+DIST phppgadmin-7.14.7.tar.gz 1154132 BLAKE2B 96321c9f2c67f8a740425b8a049a8b31320d43eedaaa2f8ceaf135d0b5b725ea168aa14715fc2df19fe9eb75d551bdb76c3821d1dbde6550dc865595ecc0ca99 SHA512 b5c6dd52e1458184a0bdb693650157c69f36d72a43df0645fde87ec7e0b3b75216dd4e1dcb3f34f95e8a0acb4bf3ec6bd9a9086a72a3ad526b80431acb476054
diff --git a/dev-db/phppgadmin/phppgadmin-7.14.7.ebuild b/dev-db/phppgadmin/phppgadmin-7.14.7.ebuild
new file mode 100644
index 000000000000..eb41f009a28a
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-7.14.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_P="phpPgAdmin-${PV}-mod"
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+SRC_URI="https://github.com/ReimuHakurei/phpPgAdmin/archive/refs/tags/v${PV}-mod.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-lang/php[postgres,session,unicode]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="BUGS CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php || die
+
+ cp -r * "${D}${MY_HTDOCSDIR}"
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}${MY_HTDOCSDIR}/${doc}" || die
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}