summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-01-17 09:24:02 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-01-17 09:24:36 +0100
commit2f7c60b31db36129c58b790c6e2a304fde6b0246 (patch)
tree5f82f298f73f1d93588c64e2740eac93ad9b36d4 /dev-db
parentapache-2.eclass: More dependency adjustments. (diff)
downloadgentoo-2f7c60b31db36129c58b790c6e2a304fde6b0246.tar.gz
gentoo-2f7c60b31db36129c58b790c6e2a304fde6b0246.tar.bz2
gentoo-2f7c60b31db36129c58b790c6e2a304fde6b0246.zip
dev-db/mysql: Add test depedency on dev-perl/JSON and restructure DEPEND/RDEPEND
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/mysql-5.6.38.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-db/mysql/mysql-5.6.38.ebuild b/dev-db/mysql/mysql-5.6.38.ebuild
index 5190600da749..dab4d3d18974 100644
--- a/dev-db/mysql/mysql-5.6.38.ebuild
+++ b/dev-db/mysql/mysql-5.6.38.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,8 +18,13 @@ IUSE="$IUSE numa"
# REMEMBER: also update eclass/mysql*.eclass before committing!
KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 ) numa? ( sys-process/numactl )"
-RDEPEND="${RDEPEND}"
+COMMON_DEPEND="numa? ( sys-process/numactl:= )"
+
+DEPEND="${COMMON_DEPEND}
+ || ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )
+ test? ( dev-perl/JSON )"
+RDEPEND="${COMMON_DEPEND}"
+
MY_PATCH_DIR="${WORKDIR}/mysql-extras-${MY_EXTRAS_VER}"