summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-09-29 16:16:03 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-09-29 16:16:03 +0200
commitd91fa40bc777293ee53ecfdc032cbee3be1272b1 (patch)
tree1bf7c5c6e0503e0279d802770958ee70e1eb32df /dev-db/pg_activity
parentnet-wireless/soapyhackrf: 0.3.3-r1 -> 0.3.4 (diff)
downloadgentoo-d91fa40bc777293ee53ecfdc032cbee3be1272b1.tar.gz
gentoo-d91fa40bc777293ee53ecfdc032cbee3be1272b1.tar.bz2
gentoo-d91fa40bc777293ee53ecfdc032cbee3be1272b1.zip
dev-db/pg_activity: version bump to 3.0.1
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-db/pg_activity')
-rw-r--r--dev-db/pg_activity/Manifest1
-rw-r--r--dev-db/pg_activity/pg_activity-3.0.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-db/pg_activity/Manifest b/dev-db/pg_activity/Manifest
index 2ad2e0710308..60f3e428cc6d 100644
--- a/dev-db/pg_activity/Manifest
+++ b/dev-db/pg_activity/Manifest
@@ -1 +1,2 @@
DIST pg_activity-3.0.0.tar.gz 293891 BLAKE2B 59e96c56ad0d315440b7fb62f3c9cb1c5131f4cf0a9dc6b0ccb153c4047d31edd47bc1711e151c070eeb965331397aa5f11545ba3bcd8e57e34764ddb1117544 SHA512 33ac8f9f143701a80c014e8067c547f9a998ff2fa0576fac1728162762d8542593d18718c89d23655a3c8270475933193a46af3bbf5856a4990d8efae0cc0732
+DIST pg_activity-3.0.1.tar.gz 421148 BLAKE2B cd6c97878671ca3881363b5ee7a67f3c6ed8f50ce36b57e087f818609e557f2d12e0405268b3c297939c31b254b0a6bce98d270954a8743645a04b86587ec778 SHA512 2a57d26090d862731b62494231005fdb13c7a132f7425a74f57c57dc004e4da61e39342d86386df4a08e5780c1f0fc170ccf962faa0872799586129e96743e30
diff --git a/dev-db/pg_activity/pg_activity-3.0.1.ebuild b/dev-db/pg_activity/pg_activity-3.0.1.ebuild
new file mode 100644
index 000000000000..6389027fa3a9
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-3.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:0[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt and not test_data.py'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}