summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-03-01 10:24:44 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-03-01 10:24:44 +0100
commitbebab38678b84cc6bc2793d20be80ea74efc4863 (patch)
treecacde1471b7f4008d517edd38131cbe1247e9957 /dev-cpp
parentdev-python/ewmh: mark Python 3.11 compatible (diff)
downloadgentoo-bebab38678b84cc6bc2793d20be80ea74efc4863.tar.gz
gentoo-bebab38678b84cc6bc2793d20be80ea74efc4863.tar.bz2
gentoo-bebab38678b84cc6bc2793d20be80ea74efc4863.zip
dev-cpp/json11: fix pkg-config file
Closes: https://bugs.gentoo.org/863098 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/json11/files/json11-1.0.0-json11.pc-do-not-state-the-defaults.patch22
-rw-r--r--dev-cpp/json11/json11-1.0.0-r1.ebuild19
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/json11/files/json11-1.0.0-json11.pc-do-not-state-the-defaults.patch b/dev-cpp/json11/files/json11-1.0.0-json11.pc-do-not-state-the-defaults.patch
new file mode 100644
index 000000000000..76b1591d1150
--- /dev/null
+++ b/dev-cpp/json11/files/json11-1.0.0-json11.pc-do-not-state-the-defaults.patch
@@ -0,0 +1,22 @@
+From d98236beaf015f2693589fca1904fb0dd01b2e6d Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@geekplace.eu>
+Date: Wed, 1 Mar 2023 10:16:49 +0100
+Subject: [PATCH] json11.pc: do not state the defaults
+
+This appearantly breaks multi-arch installations. See
+https://bugs.gentoo.org/863098
+
+Suggested-by: Thomas Scheider <qsx@chaotikum.eu>
+Signed-off-by: Florian Schmaus <flow@gentoo.org>
+--- a/json11.pc.in
++++ b/json11.pc.in
+@@ -5,5 +5,4 @@ includedir=${prefix}/include/@CMAKE_LIBRARY_ARCHITECTURE@
+ Name: @PROJECT_NAME@
+ Description: json11 is a tiny JSON library for C++11, providing JSON parsing and serialization.
+ Version: @PROJECT_VERSION@
+-Libs: -L${libdir} -ljson11
+-Cflags: -I${includedir}
++Libs: -ljson11
+--
+2.39.2
+
diff --git a/dev-cpp/json11/json11-1.0.0-r1.ebuild b/dev-cpp/json11/json11-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..31d7acab3239
--- /dev/null
+++ b/dev-cpp/json11/json11-1.0.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A tiny JSON library for C++11"
+HOMEPAGE="https://github.com/dropbox/json11"
+SRC_URI="https://github.com/dropbox/json11/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-multiarch-install.patch
+ "${FILESDIR}"/${PN}-1.0.0-json11.pc-do-not-state-the-defaults.patch
+)