summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-10 21:16:20 +0100
committerSam James <sam@gentoo.org>2024-11-11 22:24:19 +0000
commit983f4b90caa40b4b0cb9875925ebc3d721fc7f6a (patch)
tree503b9cf156a5886f1987befca5c676c31d3817d3 /dev-cpp
parentdev-cpp/edencommon: add 2024.11.04.00 (diff)
downloadgentoo-983f4b90caa40b4b0cb9875925ebc3d721fc7f6a.tar.gz
gentoo-983f4b90caa40b4b0cb9875925ebc3d721fc7f6a.tar.bz2
gentoo-983f4b90caa40b4b0cb9875925ebc3d721fc7f6a.zip
dev-cpp/cpptoml: new package, add 0.1.1
Signed-off-by: sin-ack <sin-ack@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpptoml/Manifest1
-rw-r--r--dev-cpp/cpptoml/cpptoml-0.1.1.ebuild31
-rw-r--r--dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch15
-rw-r--r--dev-cpp/cpptoml/metadata.xml22
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-cpp/cpptoml/Manifest b/dev-cpp/cpptoml/Manifest
new file mode 100644
index 000000000000..138b26feca8e
--- /dev/null
+++ b/dev-cpp/cpptoml/Manifest
@@ -0,0 +1 @@
+DIST cpptoml-0.1.1.tar.gz 47398 BLAKE2B c0ce036bec4731c4dfe96d01076b9ca18a1c4108180d5dbc839dfc44b37eb0c7af85f685a6356ef92fa684219e2883dd341e64a2012505dacc3df73dfb9e28ca SHA512 14edce576514d53a7e13562d7f8d2b66ea2b95f44038396c0e26232ec81783042ebecec31ee272a99afef96d5c8582a8e81ea5167a787844b98de6ee6f545cc5
diff --git a/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild b/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild
new file mode 100644
index 000000000000..27c81a63572b
--- /dev/null
+++ b/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Header-only library for parsing TOML"
+HOMEPAGE="https://github.com/skystrife/cpptoml"
+SRC_URI="https://github.com/skystrife/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+PATCHES=(
+ "${FILESDIR}/${P}-limits.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPPTOML_BUILD_EXAMPLES=$(usex examples)
+ )
+
+ if [[ $(tc-get-cxx-stdlib) == libc++ ]]; then
+ mycmakeargs+=(-DENABLE_LIBCXX=ON)
+ fi
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch b/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch
new file mode 100644
index 000000000000..484f98044be4
--- /dev/null
+++ b/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch
@@ -0,0 +1,15 @@
+From c55a516e90133d89d67285429c6474241346d27a Mon Sep 17 00:00:00 2001
+From: Dirk Eddelbuettel <edd@debian.org>
+Date: Mon, 30 Nov 2020 09:41:49 -0600
+Subject: [PATCH] g++-11 requires limits header
+
+--- a/include/cpptoml.h
++++ b/include/cpptoml.h
+@@ -14,6 +14,7 @@
+ #include <cstring>
+ #include <fstream>
+ #include <iomanip>
++#include <limits>
+ #include <map>
+ #include <memory>
+ #include <sstream>
diff --git a/dev-cpp/cpptoml/metadata.xml b/dev-cpp/cpptoml/metadata.xml
new file mode 100644
index 000000000000..88ca6c8a4ea6
--- /dev/null
+++ b/dev-cpp/cpptoml/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+A header-only library for parsing TOML configuration files.
+
+Targets: TOML v0.5.0 as of August 2018.
+
+This includes support for the new DateTime format, inline tables, multi-line basic and raw strings, digit separators, hexadecimal integers, octal integers, binary integers, and float special values.
+ </longdescription>
+ <maintainer type="person" proxied="yes">
+ <email>sin-ack@protonmail.com</email>
+ <name>sin-ack</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ddemidov/vexcl</remote-id>
+ </upstream>
+</pkgmetadata>