summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-03 23:46:40 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-04 01:19:28 +0100
commit29a7b637d9cef988cc061a9690d4e1d716ba6f62 (patch)
treef39a9f8f458f2b9bfab378ba867b79f216f18352 /dev-cpp
parentdev-build/bazelisk: drop old 1.20.0 (diff)
downloadgentoo-29a7b637d9cef988cc061a9690d4e1d716ba6f62.tar.gz
gentoo-29a7b637d9cef988cc061a9690d4e1d716ba6f62.tar.bz2
gentoo-29a7b637d9cef988cc061a9690d4e1d716ba6f62.zip
dev-cpp/cpp-httplib: drop old 0.16.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpp-httplib/Manifest1
-rw-r--r--dev-cpp/cpp-httplib/cpp-httplib-0.16.3.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-cpp/cpp-httplib/Manifest b/dev-cpp/cpp-httplib/Manifest
index 3f22f1761767..3f8ddbaa180b 100644
--- a/dev-cpp/cpp-httplib/Manifest
+++ b/dev-cpp/cpp-httplib/Manifest
@@ -1,3 +1,2 @@
-DIST cpp-httplib-0.16.3.tar.gz 1157548 BLAKE2B 986a33043ddf86623f70f50244051089cb6b824866ee247de13772263c691fde2b10e9eeef2078265f0a91b5744dafd2940892cff03c1a9cfd4b35df0d446522 SHA512 1a0d40f17b526db74dfa51903f0d15876b20c836a438be8f87ac2b18e535c3fad1822fbad9cf97053705a2cedc8171ab648e2e8c823eeb2e180c347283f3de9a
DIST cpp-httplib-0.18.0.tar.gz 1321763 BLAKE2B 7807c2f4e3a6a0703a1253f0ec4ac7ef5fbcfad000e517af034a2aff64393229fb47830d215a1959e9893a66f51d19989c33b6b646b79be71e69687fe08cbbf2 SHA512 35ff903d51fee5428d7a95a0406460f8a18d1b5653f6ec8f353d7a2f1084598e599b24d0401f7214d5ee8d9764c74a4e617fff55acd4e6733ab1b9f2d7d4403c
DIST cpp-httplib-0.18.1.tar.gz 1323636 BLAKE2B 8335c9a4d69d7e9b2e7e3c4036b49627536c8d6cffa7a5ae2c3dff693c5458f7fa2f89f3da2c130325069225d3204ec579900d5c5266dff7a9c732c134b39907 SHA512 6dd1054d0171594bf871a918b5540cc67981a48f7dbb82e9029a4877afc6d8c36e2f69411f5eec7b052bf0245554d01f33ef2180f42a15f6b8dd86ebb2427a41
diff --git a/dev-cpp/cpp-httplib/cpp-httplib-0.16.3.ebuild b/dev-cpp/cpp-httplib/cpp-httplib-0.16.3.ebuild
deleted file mode 100644
index 82aa4bbda953..000000000000
--- a/dev-cpp/cpp-httplib/cpp-httplib-0.16.3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{11..13} )
-
-inherit cmake-multilib python-any-r1 toolchain-funcs
-
-DESCRIPTION="C++ HTTP/HTTPS server and client library"
-HOMEPAGE="https://github.com/yhirose/cpp-httplib/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/yhirose/${PN}.git"
-else
- SRC_URI="https://github.com/yhirose/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
- KEYWORDS="~alpha amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/$(ver_cut 1-2)" # soversion
-
-IUSE="brotli ssl test zlib"
-REQUIRED_USE="test? ( brotli ssl zlib )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- brotli? (
- app-arch/brotli:=[${MULTILIB_USEDEP}]
- )
- ssl? (
- >=dev-libs/openssl-3.0.13:=[${MULTILIB_USEDEP}]
- )
- zlib? (
- sys-libs/zlib[${MULTILIB_USEDEP}]
- )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- ${PYTHON_DEPS}
-"
-
-src_configure() {
- local -a mycmakeargs=(
- -DHTTPLIB_COMPILE=yes
- -DBUILD_SHARED_LIBS=yes
- -DHTTPLIB_USE_BROTLI_IF_AVAILABLE=no
- -DHTTPLIB_USE_OPENSSL_IF_AVAILABLE=no
- -DHTTPLIB_USE_ZLIB_IF_AVAILABLE=no
- -DHTTPLIB_REQUIRE_BROTLI=$(usex brotli)
- -DHTTPLIB_REQUIRE_OPENSSL=$(usex ssl)
- -DHTTPLIB_REQUIRE_ZLIB=$(usex zlib)
- -DPython3_EXECUTABLE="${PYTHON}"
- )
- cmake-multilib_src_configure
-}
-
-multilib_src_test() {
- cp -p -R --reflink=auto "${S}/test" ./test || die
-
- local -a failing_tests=(
- # Disable all online tests.
- "*.*_Online"
-
- # Fails on musl x86:
- ServerTest.GetRangeWithMaxLongLength
- ServerTest.GetStreamedWithTooManyRanges
-
- # https://github.com/yhirose/cpp-httplib/issues/1798
- # Filed by mgorny's testing, fails on openssl >=3.2:
- SSLClientServerTest.ClientCertPresent
- SSLClientServerTest.ClientEncryptedCertPresent
- SSLClientServerTest.CustomizeServerSSLCtx
- SSLClientServerTest.MemoryClientCertPresent
- SSLClientServerTest.MemoryClientEncryptedCertPresent
- SSLClientServerTest.TrustDirOptional
- )
-
- # Little dance to please the GTEST filter (join array using ":").
- failing_tests_str="${failing_tests[@]}"
- failing_tests_filter="${failing_tests_str// /:}"
-
- # PREFIX is . to avoid calling "brew" and relying on stuff in /opt
- GTEST_FILTER="-${failing_tests_filter}" emake -C test \
- CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} -I." PREFIX=.
-}