summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-10-30 08:19:07 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-10-30 08:56:54 +0100
commit07246f388785090f90ca8a7926c295ba51c62057 (patch)
treec8cc4a164fdb0f9bbaccccc3566aef3b5e9fce49 /dev-cpp
parentdev-cpp/scitokens-cpp: stabilize 1.0.2-r1 for amd64, x86 (diff)
downloadgentoo-07246f388785090f90ca8a7926c295ba51c62057.tar.gz
gentoo-07246f388785090f90ca8a7926c295ba51c62057.tar.bz2
gentoo-07246f388785090f90ca8a7926c295ba51c62057.zip
dev-cpp/scitokens-cpp: drop 1.0.1, 1.0.1-r1
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/scitokens-cpp/Manifest1
-rw-r--r--dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1-r1.ebuild57
-rw-r--r--dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild34
3 files changed, 0 insertions, 92 deletions
diff --git a/dev-cpp/scitokens-cpp/Manifest b/dev-cpp/scitokens-cpp/Manifest
index c5597ff8eb5a..af16dfad5971 100644
--- a/dev-cpp/scitokens-cpp/Manifest
+++ b/dev-cpp/scitokens-cpp/Manifest
@@ -1,2 +1 @@
-DIST scitokens-cpp-1.0.1.tar.gz 309430 BLAKE2B cfb0a25bde68076334d37d0b47adcb2f1b794bf60330f612c3bfbe2588e420a2b427e9e9916ee14c2c348ed4448d781fad2068d35560b45740b81144aa12e6a6 SHA512 592d8c473ecdeed49c5552239d98e4da57313c8914b3c97c74a6bc4b1f4929b4490a33695e741972a8c83f6097d644fc4df94b3ca54d811c64dcf542b6467ea9
DIST scitokens-cpp-1.0.2.tar.gz 311221 BLAKE2B 8f77f4f5ded34f7c572567c980ef0dabaf7e36d4395d41046a1bd8e1343299309ea81efb23b0120532cba365463a9ad2c5ff857f85be5df922830541513c11cd SHA512 c15784342eb70eb0ec1cd87d5a1e89446b8aa3bb070bfdef58960c2d94739b05d186ee33807ebc066a450a0211b3dd7c04ea613fd4870d7a2d0f8fe30e8a7453
diff --git a/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1-r1.ebuild b/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1-r1.ebuild
deleted file mode 100644
index 8f7d8ed53bee..000000000000
--- a/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/scitokens/scitokens-cpp"
-else
- SRC_URI="https://github.com/scitokens/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="C++ implementation of the SciTokens library with a C library interface"
-HOMEPAGE="https://scitokens.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-DEPEND="
- dev-cpp/jwt-cpp[picojson]
- dev-db/sqlite
- dev-libs/openssl:0=
- net-misc/curl:0=
- kernel_linux? ( sys-apps/util-linux )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( dev-cpp/gtest )
-"
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- # Unbundle dev-cpp/gtest, dev-cpp/jwt-cpp
- rm -r vendor || die
- # Fix include path for picojson.
- find src/ \( -name '*.cpp' -o -name '*.h' \) -type f -print0 | \
- xargs -0 sed -r -e "s:picojson/picojson\.h:picojson.h:g" -i || die
- # Disable network-based tests relying on external services.
- if use test; then
- sed -i -e '/^TEST_F/s#RefreshTest#DISABLED_RefreshTest#' \
- -e '/^TEST_F/s#RefreshExpiredTest#DISABLED_RefreshExpiredTest#' test/main.cpp || die
- fi
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSCITOKENS_BUILD_UNITTESTS="$(usex test)"
- -DSCITOKENS_EXTERNAL_GTEST=YES
- )
- cmake_src_configure
-}
diff --git a/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild b/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
deleted file mode 100644
index e78e7a103c72..000000000000
--- a/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="C++ implementation of the SciTokens library with a C library interface"
-HOMEPAGE="https://github.com/scitokens/scitokens-cpp"
-SRC_URI="https://github.com/scitokens/scitokens-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RESTRICT="test" # testing requires network
-
-DEPEND="
- dev-db/sqlite
- dev-libs/openssl:0=
- net-misc/curl:0=
- kernel_linux? ( sys-apps/util-linux )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="test? ( dev-cpp/gtest )"
-
-src_configure() {
- local mycmakeargs=(
- -DSCITOKENS_BUILD_UNITTESTS=$(usex test)
- -DSCITOKENS_EXTERNAL_GTEST=1
- )
- cmake_src_configure
-}