summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-07 00:46:27 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-07 00:46:46 +0200
commitb7deaa00a74a445c4147d3dcd5df94f9f9b5418a (patch)
treec586e010622d5146cd8fb7dabc1653de0dfaf9c1 /dev-cpp/libcutl/libcutl-1.10.0.ebuild
parentsys-apps/openrc: 0.30 version bump (diff)
downloadgentoo-b7deaa00a74a445c4147d3dcd5df94f9f9b5418a.tar.gz
gentoo-b7deaa00a74a445c4147d3dcd5df94f9f9b5418a.tar.bz2
gentoo-b7deaa00a74a445c4147d3dcd5df94f9f9b5418a.zip
dev-cpp/libcutl: Use std::regex over boost::regex
* boost-1.65.0 has removed TR1 support. It's 2017 and we can use C++11's <regex> support now. Closes: https://bugs.gentoo.org/show_bug.cgi?id=630016 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-cpp/libcutl/libcutl-1.10.0.ebuild')
-rw-r--r--dev-cpp/libcutl/libcutl-1.10.0.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-cpp/libcutl/libcutl-1.10.0.ebuild b/dev-cpp/libcutl/libcutl-1.10.0.ebuild
index c44786235d64..652471ccb886 100644
--- a/dev-cpp/libcutl/libcutl-1.10.0.ebuild
+++ b/dev-cpp/libcutl/libcutl-1.10.0.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit versionator
+inherit autotools flag-o-matic versionator
DESCRIPTION="A collection of C++ libraries (successor of libcult)"
HOMEPAGE="http://www.codesynthesis.com/projects/libcutl/"
SRC_URI="http://www.codesynthesis.com/download/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
@@ -18,16 +19,25 @@ RDEPEND="
dev-libs/boost:="
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-1.10.0-fix-c++14.patch" )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.0-fix-c++14.patch
+ "${FILESDIR}"/${PN}-1.10.0-boost-1.65-tr1.patch
+)
src_prepare() {
default
# remove bundled libs
rm -r cutl/details/{boost,expat} || die
+
+ eautoreconf
}
src_configure() {
+ # ensure <regex> works on GCC 5 and below
+ # bug 630016
+ append-cxxflags -std=c++14
+
econf \
--disable-static \
--with-external-boost \