summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-05-11 18:21:38 +0200
committerDavid Seifert <soap@gentoo.org>2024-05-11 18:21:38 +0200
commit9883070cdb88a131361656d23d6ad14a2b1ea825 (patch)
tree7d49ca71af6062b7357cddda40fe92066f50c8ca /dev-cpp/catch/catch-3.6.0.ebuild
parentapp-editors/sublime-text: drop versions (diff)
downloadgentoo-9883070cdb88a131361656d23d6ad14a2b1ea825.tar.gz
gentoo-9883070cdb88a131361656d23d6ad14a2b1ea825.tar.bz2
gentoo-9883070cdb88a131361656d23d6ad14a2b1ea825.zip
dev-cpp/catch: add 3.6.0
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/catch/catch-3.6.0.ebuild')
-rw-r--r--dev-cpp/catch/catch-3.6.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-3.6.0.ebuild b/dev-cpp/catch/catch-3.6.0.ebuild
new file mode 100644
index 000000000000..cde2d006ed7f
--- /dev/null
+++ b/dev-cpp/catch/catch-3.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake python-any-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_DEVELOPMENT_BUILD=ON
+ -DCATCH_ENABLE_WERROR=OFF
+ -DCATCH_BUILD_TESTING=$(usex test)
+ )
+ use test && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+}