summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-11-09 20:23:38 +0100
committerTupone Alfredo <tupone@gentoo.org>2019-11-09 20:24:14 +0100
commit9f010c63f50a650dea85493ac4e9dfb3f235c22b (patch)
tree3c7d2543eb6e6a2f3ddfe7ee42a2faf61e44a884 /dev-ada/libadalang
parentsys-kernel/gentoo-sources: amd64 stable (#699556) (diff)
downloadgentoo-9f010c63f50a650dea85493ac4e9dfb3f235c22b.tar.gz
gentoo-9f010c63f50a650dea85493ac4e9dfb3f235c22b.tar.bz2
gentoo-9f010c63f50a650dea85493ac4e9dfb3f235c22b.zip
dev-ada: remove some old style ada ebuild
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/libadalang')
-rw-r--r--dev-ada/libadalang/libadalang-2018-r1.ebuild62
-rw-r--r--dev-ada/libadalang/libadalang-2019.ebuild68
2 files changed, 0 insertions, 130 deletions
diff --git a/dev-ada/libadalang/libadalang-2018-r1.ebuild b/dev-ada/libadalang/libadalang-2018-r1.ebuild
deleted file mode 100644
index 21136132a52f..000000000000
--- a/dev-ada/libadalang/libadalang-2018-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-MYP=${PN}-gpl-${PV}-src
-DESCRIPTION="high performance semantic engine for the Ada programming language"
-HOMEPAGE="https://libre.adacore.com/"
-SRC_URI="http://mirrors.cdn.adacore.com/art/5b0cf9adc7a4475263382c18
- -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3 gcc-runtime-library-exception-3.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnat_2017 +gnat_2018 gnat_2019 +shared static-libs"
-
-RDEPEND="dev-python/pyyaml
- dev-ada/gnatcoll-bindings[gnat_2017(-)?,gnat_2018(-)?,gnat_2019(-)?]
- dev-ada/gnatcoll-bindings[iconv,shared=,static-libs=]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- ~dev-ada/langkit-2018
- dev-ada/gprbuild[gnat_2017(-)?,gnat_2018(-)?,gnat_2019(-)?]"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ^^ ( gnat_2017 gnat_2018 gnat_2019 )"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${PN}-2017-gentoo.patch
-)
-
-src_configure() {
- ada/manage.py -v debug generate || die
-}
-
-src_compile() {
- ada/manage.py \
- -v \
- $(use_enable shared) \
- $(use_enable static-libs static) \
- build \
- --build-mode='prod' || die
-}
-
-src_test () {
- ada/manage.py test | grep FAILED && die
-}
-
-src_install () {
- ada/manage.py \
- $(use_enable shared) \
- $(use_enable static-libs static) \
- install "${D}"usr || die
- python_domodule build/python/libadalang.py
- rm -r "${D}"usr/python || die
-}
diff --git a/dev-ada/libadalang/libadalang-2019.ebuild b/dev-ada/libadalang/libadalang-2019.ebuild
deleted file mode 100644
index b82f0de8e748..000000000000
--- a/dev-ada/libadalang/libadalang-2019.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-MYP=${P}-20190510-19916-src
-DESCRIPTION="high performance semantic engine for the Ada programming language"
-HOMEPAGE="https://libre.adacore.com/"
-SRC_URI="http://mirrors.cdn.adacore.com/art/5cdf8f3331e87a8f1c967d27
- -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3 gcc-runtime-library-exception-3.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnat_2018 +gnat_2019 +shared static-libs"
-
-RDEPEND="dev-python/pyyaml
- dev-ada/gnatcoll-bindings[gnat_2018(-)?,gnat_2019(-)?]
- dev-ada/gnatcoll-bindings[iconv,shared=,static-libs=]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[gnat_2018(-)?,gnat_2019(-)?]
- >=dev-ada/langkit-2019"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ^^ ( gnat_2018 gnat_2019 )"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-src_configure() {
- ada/manage.py -v debug generate || die
-}
-
-src_compile() {
- libtype=relocatable
- if use shared; then
- if use static-libs; then
- libtype=static,relocatable
- fi
- elif use static-libs; then
- libtype=static
- fi
- ada/manage.py \
- -v \
- --library-types $libtype \
- build \
- --build-mode='prod' || die
-}
-
-src_test () {
- ada/manage.py test | tee libadalang.testOut;
- grep -q FAILED libadalang.testOut && die
-}
-
-src_install () {
- ada/manage.py \
- -v \
- --library-types $libtype \
- install "${D}"/usr || die
- python_domodule build/python/libadalang
- rm -r "${D}"/usr/python || die
-}