summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ada/charles
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ada/charles')
-rw-r--r--dev-ada/charles/Manifest1
-rw-r--r--dev-ada/charles/charles-20050913.ebuild50
-rw-r--r--dev-ada/charles/metadata.xml6
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-ada/charles/Manifest b/dev-ada/charles/Manifest
new file mode 100644
index 000000000000..73630fbb3d95
--- /dev/null
+++ b/dev-ada/charles/Manifest
@@ -0,0 +1 @@
+DIST charles-20050913.tar.bz2 4098538 SHA256 a6dc507769aec161391c6608417726d6c17feebcc423442b6c6784c5bfeaa792 SHA512 a2a42c1c14555ce8a3384c5af0fb0a8a017874a0c6a220464fe163ab66428def8878d2f7231f9749064f15e4aaf34d06f87d9433d9b277fbf48202294900bd6b WHIRLPOOL de0287be1fe0cfc07b7e81d8062b3e6acf244f4aaacbea53bee0dfb242442fe04c857269b0cea6df420691a6e36ee1abdd5abe027ea49f8fd5d4dfa0b90fedcf
diff --git a/dev-ada/charles/charles-20050913.ebuild b/dev-ada/charles/charles-20050913.ebuild
new file mode 100644
index 000000000000..5ebbc71525e3
--- /dev/null
+++ b/dev-ada/charles/charles-20050913.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnat
+
+IUSE=""
+
+DESCRIPTION="Posix bindings for Ada"
+HOMEPAGE="http://libre2.adacore.com/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/ada"
+
+S="${WORKDIR}/${PN}"
+
+lib_compile()
+{
+ einfo "nothing to do here"
+}
+
+# NOTE: we are using $1 - the passed gnat profile name
+lib_install()
+{
+ einfo "nothing to do here"
+}
+
+src_install ()
+{
+ # install sources
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins src/*.ad?
+
+ #set up environment
+ #echo "PATH=%DL%/bin" > ${LibEnv}
+ #echo "LDPATH=%DL%" >> ${LibEnv}
+ #echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=/usr/include/ada/${PN}" > ${LibEnv}
+
+ gnat_src_install
+
+ dodoc src/{COPYING.TXT,README.txt}
+ insinto /usr/share/doc/${PF}
+ doins -r src/testdir/ www/charles_tutorial.pdf
+}
diff --git a/dev-ada/charles/metadata.xml b/dev-ada/charles/metadata.xml
new file mode 100644
index 000000000000..c589105f804a
--- /dev/null
+++ b/dev-ada/charles/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ada</herd>
+<longdescription>Charles is a data structure library for Ada95, modelled principally on the C++ STL. It features both ordered (lists and arrays) and unordered (sets and maps) collections. In addition to lists and vectors, the Charles library has set, multi-set, map, and multi-map data structure types.</longdescription>
+</pkgmetadata>