summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Yelloz <jordan@yelloz.me>2022-09-24 21:37:11 -0600
committerSam James <sam@gentoo.org>2022-09-25 04:47:13 +0100
commitfd1ca93047532ca046f0772c64e33974e3181e39 (patch)
tree7c918869144d98f61f60f0440fb1c5f2d81dcfdf /app-text
parentgo-module.eclass: suggest XZ options and preferences for compression (diff)
downloadgentoo-fd1ca93047532ca046f0772c64e33974e3181e39.tar.gz
gentoo-fd1ca93047532ca046f0772c64e33974e3181e39.tar.bz2
gentoo-fd1ca93047532ca046f0772c64e33974e3181e39.zip
app-text/qpdf: Fixed DEFAULT_CRYPTO value.
The DEFAULT_CRYPTO argument expects the values to be in lowercase. Closes: https://bugs.gentoo.org/872716 Signed-off-by: Jordan Yelloz <jordan@yelloz.me> Closes: https://github.com/gentoo/gentoo/pull/27434 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/qpdf/qpdf-11.1.0-r2.ebuild (renamed from app-text/qpdf/qpdf-11.1.0-r1.ebuild)3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-text/qpdf/qpdf-11.1.0-r1.ebuild b/app-text/qpdf/qpdf-11.1.0-r2.ebuild
index f0a13b28829a..774c671b8246 100644
--- a/app-text/qpdf/qpdf-11.1.0-r1.ebuild
+++ b/app-text/qpdf/qpdf-11.1.0-r2.ebuild
@@ -52,8 +52,9 @@ src_configure() {
if use ssl ; then
local crypto_provider=$(usex gnutls GNUTLS OPENSSL)
+ local crypto_provider_lowercase=${crypto_provider,,}
mycmakeargs+=(
- -DDEFAULT_CRYPTO=${crypto_provider}
+ -DDEFAULT_CRYPTO=${crypto_provider_lowercase}
-DREQUIRE_CRYPTO_${crypto_provider}=ON
)
fi