summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-09-11 10:31:56 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-09-11 10:31:56 +0200
commitd1dface786a6362f84037fef8947e13e4e38f112 (patch)
tree03386c07234f00c6ce48268037013056ff59c399 /app-text/xml2rfc
parentdev-java/gradle-bin: add 8.3 (diff)
downloadgentoo-d1dface786a6362f84037fef8947e13e4e38f112.tar.gz
gentoo-d1dface786a6362f84037fef8947e13e4e38f112.tar.bz2
gentoo-d1dface786a6362f84037fef8947e13e4e38f112.zip
app-text/xml2rfc: add 3.18.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/xml2rfc')
-rw-r--r--app-text/xml2rfc/Manifest1
-rw-r--r--app-text/xml2rfc/xml2rfc-3.18.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/xml2rfc/Manifest b/app-text/xml2rfc/Manifest
index 79323ad37f71..33223c01b4c9 100644
--- a/app-text/xml2rfc/Manifest
+++ b/app-text/xml2rfc/Manifest
@@ -1 +1,2 @@
DIST xml2rfc-3.17.4.gh.tar.gz 2858770 BLAKE2B b29b8a102668a5aa943a32b28a9d1669e2a6b0af03085a550c21a08e5bfb5ff3ee8979b03a3d7ae8e820ac8bf60455682914fd06a882e17183ca51aaf1dedf86 SHA512 3fc620eed12fc2a7f6015df8b6a5b1aa422cd8c26807e01d75498aee9257faad1bca68606f77598fb040a8dae074e35ffa0e2994a1ae8d59ee27d25fc6a755e5
+DIST xml2rfc-3.18.0.gh.tar.gz 2856552 BLAKE2B b2397d10c770694e8eb354220803f89525e64638fd1043c2672ce0849be72a397ab6f2bff03f689721f00e63ac034ec7b7aec20cf93b759f42a415ab66293908 SHA512 afd88bad84c6f5b734dd091e34ec41bff63fcf38f3bfab777818954dec31363300e13dd745b602e2c145fbe0df0be4e69918ddc71aac276bf0833ad4563c19f1
diff --git a/app-text/xml2rfc/xml2rfc-3.18.0.ebuild b/app-text/xml2rfc/xml2rfc-3.18.0.ebuild
new file mode 100644
index 000000000000..3b8c97ef1ad8
--- /dev/null
+++ b/app-text/xml2rfc/xml2rfc-3.18.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generates RFCs and IETF drafts from document source in XML"
+HOMEPAGE="https://ietf-tools.github.io/xml2rfc/ https://github.com/ietf-tools/xml2rfc"
+SRC_URI="https://github.com/ietf-tools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+RESTRICT="!test? ( test )"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/dict2xml[${PYTHON_USEDEP}]
+ dev-python/weasyprint[${PYTHON_USEDEP}]
+ media-fonts/noto[cjk]
+ )
+"
+
+RDEPEND="
+ >=dev-python/platformdirs-3.6.0[${PYTHON_USEDEP}]
+ dev-python/ConfigArgParse[${PYTHON_USEDEP}]
+ dev-python/intervaltree[${PYTHON_USEDEP}]
+ >=dev-python/google-i18n-address-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ # Disable broken PdfWriterTests.
+ sed -i 's/ PdfWriterTests(unittest.TestCase):/ PdfWriterTests:/' test.py || die
+}