summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 09:53:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 10:04:41 +0200
commit68496933adcb964398fd00f85adc8d703266a771 (patch)
treeec748c38683393a3557203695bc3e2065d45e5ab /app-text/stardict
parentapp-text/pdfminer: Remove old (diff)
downloadgentoo-68496933adcb964398fd00f85adc8d703266a771.tar.gz
gentoo-68496933adcb964398fd00f85adc8d703266a771.tar.bz2
gentoo-68496933adcb964398fd00f85adc8d703266a771.zip
app-text/stardict: Eradicate python2
Closes: https://bugs.gentoo.org/735248 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-text/stardict')
-rw-r--r--app-text/stardict/stardict-3.0.6-r4.ebuild (renamed from app-text/stardict/stardict-3.0.6-r3.ebuild)21
-rw-r--r--app-text/stardict/stardict-4.0.0_pre20170304-r1.ebuild (renamed from app-text/stardict/stardict-4.0.0_pre20170304.ebuild)21
2 files changed, 4 insertions, 38 deletions
diff --git a/app-text/stardict/stardict-3.0.6-r3.ebuild b/app-text/stardict/stardict-3.0.6-r4.ebuild
index 66ab1895618e..c41fc396803b 100644
--- a/app-text/stardict/stardict-3.0.6-r3.ebuild
+++ b/app-text/stardict/stardict-3.0.6-r4.ebuild
@@ -8,9 +8,8 @@ EAPI=6
# seperate for now.
GNOME2_LA_PUNT=yes
-PYTHON_COMPAT=( python2_7 )
-inherit flag-o-matic gnome2 python-single-r1
+inherit flag-o-matic gnome2
DESCRIPTION="A international dictionary supporting fuzzy and glob style matching"
HOMEPAGE="http://stardict-4.sourceforge.net/"
@@ -22,7 +21,7 @@ LICENSE="CPL-1.0 GPL-3 LGPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 sparc x86"
IUSE="advertisement debug dictdotcn espeak examples +gucharmap
-+htmlparse man perl +powerwordparse pronounce python qqwry spell
++htmlparse man perl +powerwordparse pronounce qqwry spell
tools updateinfo +wikiparse +wordnet +xdxfparse"
RESTRICT="test"
@@ -41,7 +40,6 @@ COMMON_DEPEND="
dev-db/mysql-connector-c
dev-libs/libpcre:=
dev-libs/libxml2:=
- python? ( ${PYTHON_DEPS} )
)
"
RDEPEND="${COMMON_DEPEND}
@@ -56,7 +54,6 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext
virtual/pkgconfig
"
-REQUIRED_USE="tools? ( python? ( ${PYTHON_REQUIRED_USE} ) )"
# docs are messy, installed manually below
DOCS=""
@@ -71,17 +68,6 @@ src_prepare() {
# libsigc++ started to require c++11 support
append-cxxflags "-std=c++11"
- if use python; then
- local f
- # force python shebangs handlable by python_doscript
- for f in tools/src/*.py; do
- [[ $(head -n1 "${f}") =~ ^#! ]] || continue
- sed -i '1 s|.*|#!/usr/bin/python|' tools/src/*.py || die
- done
- # script contains UTF-8 symbols, but has no ecoding set
- sed -i '1 a # -*- coding: utf-8 -*-' tools/src/uyghur2dict.py || die
- fi
-
eapply_user
gnome2_src_prepare
}
@@ -162,8 +148,6 @@ src_install() {
${PN}-bin2text ${PN}-repair"
use perl && apps+=" dicts-dump.pl ncce2stardict.pl parse-oxford.perl"
- use python && apps+=" hanzim2dict.py jm2stardict.py lingea-trd-decoder.py
- makevietdict.py uyghur2dict.py"
for app in ${apps}; do
if [[ "${app}" =~ ^${PN} ]]; then
@@ -172,7 +156,6 @@ src_install() {
newbin "tools/src/${app}" "${PN}_${app}"
fi
done
- use python && python_doscript "${ED}"usr/bin/*.py
docinto tools
dodoc tools/{AUTHORS,ChangeLog,README}
diff --git a/app-text/stardict/stardict-4.0.0_pre20170304.ebuild b/app-text/stardict/stardict-4.0.0_pre20170304-r1.ebuild
index 068d4a3d51c6..41900b018b60 100644
--- a/app-text/stardict/stardict-4.0.0_pre20170304.ebuild
+++ b/app-text/stardict/stardict-4.0.0_pre20170304-r1.ebuild
@@ -8,9 +8,8 @@ EAPI=6
# seperate for now.
GNOME2_LA_PUNT=yes
-PYTHON_COMPAT=( python2_7 )
-inherit autotools flag-o-matic gnome2 python-single-r1
+inherit autotools flag-o-matic gnome2
DESCRIPTION="A international dictionary supporting fuzzy and glob style matching"
HOMEPAGE="http://stardict-4.sourceforge.net/
@@ -24,7 +23,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="advertisement cal debug dictdotcn espeak examples flite
fortune gucharmap +htmlparse info man perl +powerwordparse
-pronounce python qqwry spell tools updateinfo +wikiparse +wordnet
+pronounce qqwry spell tools updateinfo +wikiparse +wordnet
+xdxfparse youdaodict"
RESTRICT="test"
@@ -47,7 +46,6 @@ COMMON_DEPEND="
dev-libs/expat
dev-libs/libpcre:=
dev-libs/libxml2:=
- python? ( ${PYTHON_DEPS} )
)
"
RDEPEND="${COMMON_DEPEND}
@@ -63,7 +61,6 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext
virtual/pkgconfig
"
-REQUIRED_USE="tools? ( python? ( ${PYTHON_REQUIRED_USE} ) )"
# docs are messy, installed manually below
DOCS=""
@@ -80,17 +77,6 @@ src_prepare() {
# libsigc++ started to require c++11 support
append-cxxflags "-std=c++11"
- if use python; then
- local f
- # force python shebangs handlable by python_doscript
- for f in tools/src/*.py; do
- [[ $(head -n1 "${f}") =~ ^#! ]] || continue
- sed -i '1 s|.*|#!/usr/bin/python|' tools/src/*.py || die
- done
- # script contains UTF-8 symbols, but has no ecoding set
- sed -i '1 a # -*- coding: utf-8 -*-' tools/src/uyghur2dict.py || die
- fi
-
# bug 604318
sed -i '/AM_GCONF_SOURCE_2/d' dict/configure.ac || die
@@ -179,8 +165,6 @@ src_install() {
${PN}-text2bin ${PN}-bin2text ${PN}-repair"
use perl && apps+=" dicts-dump.pl ncce2stardict.pl parse-oxford.perl"
- use python && apps+=" hanzim2dict.py jm2stardict.py lingea-trd-decoder.py
- makevietdict.py uyghur2dict.py"
for app in ${apps}; do
if [[ "${app}" =~ ^${PN} ]]; then
@@ -189,7 +173,6 @@ src_install() {
newbin "tools/src/${app}" "${PN}_${app}"
fi
done
- use python && python_doscript "${ED}"usr/bin/*.py
docinto tools
dodoc tools/{AUTHORS,ChangeLog,README}