summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-25 09:55:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-25 10:02:11 +0300
commit2dc1d5534a2c067fc129497905211bc0d0cf89db (patch)
treed042d756e8f5d37728a1b7879f4f019eaa031239 /app-text/sablotron/sablotron-1.0.3-r3.ebuild
parentapp-text/sablotron: Fix C++17 does not allow register storage class (diff)
downloadgentoo-2dc1d5534a2c067fc129497905211bc0d0cf89db.tar.gz
gentoo-2dc1d5534a2c067fc129497905211bc0d0cf89db.tar.bz2
gentoo-2dc1d5534a2c067fc129497905211bc0d0cf89db.zip
app-text/sablotron: cleanup, rename patches
- use array for econf args - add ${PN} prefix to FILESDIR patches - organize global scope assignments Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text/sablotron/sablotron-1.0.3-r3.ebuild')
-rw-r--r--app-text/sablotron/sablotron-1.0.3-r3.ebuild36
1 files changed, 15 insertions, 21 deletions
diff --git a/app-text/sablotron/sablotron-1.0.3-r3.ebuild b/app-text/sablotron/sablotron-1.0.3-r3.ebuild
index 75dc3320a516..d702dafc4941 100644
--- a/app-text/sablotron/sablotron-1.0.3-r3.ebuild
+++ b/app-text/sablotron/sablotron-1.0.3-r3.ebuild
@@ -5,13 +5,12 @@ EAPI=8
inherit autotools
-MY_PN="Sablot"
-MY_P="${MY_PN}-${PV}"
-S=${WORKDIR}/${MY_P}
+MY_P="Sablot-${PV}"
DESCRIPTION="An XSLT Parser in C++"
HOMEPAGE="https://sourceforge.net/projects/sablotron/"
SRC_URI="mirror://sourceforge/sablotron/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
# Sablotron can optionally be built under GPL, using MPL for now
LICENSE="MPL-1.1"
@@ -19,22 +18,16 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="perl"
-RDEPEND="
- >=dev-libs/expat-1.95.6-r1
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- >=dev-perl/XML-Parser-2.3
-"
-DOCS=(
- README README_JS RELEASE src/TODO
-)
+DEPEND=">=dev-libs/expat-1.95.6-r1"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-perl/XML-Parser-2.3"
+
+DOCS=( README README_JS RELEASE src/TODO )
+
PATCHES=(
- "${FILESDIR}"/1.0.3-libsablot-expat.patch
- "${FILESDIR}"/1.0.3-cxx11.patch
- "${FILESDIR}"/1.0.3-drop-register-keyword.patch
+ "${FILESDIR}"/${PN}-1.0.3-libsablot-expat.patch
+ "${FILESDIR}"/${PN}-1.0.3-cxx11.patch
+ "${FILESDIR}"/${PN}-1.0.3-drop-register-keyword.patch
)
src_prepare() {
@@ -45,10 +38,11 @@ src_prepare() {
}
src_configure() {
- econf \
- --disable-static \
- $(use_enable perl perlconnect) \
+ local myeconfargs=(
+ $(use_enable perl perlconnect)
--with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {