summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/htp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/htp')
-rw-r--r--app-text/htp/Manifest1
-rw-r--r--app-text/htp/files/strip.patch15
-rw-r--r--app-text/htp/htp-1.16-r1.ebuild50
-rw-r--r--app-text/htp/metadata.xml8
4 files changed, 74 insertions, 0 deletions
diff --git a/app-text/htp/Manifest b/app-text/htp/Manifest
new file mode 100644
index 000000000000..f722dc91f051
--- /dev/null
+++ b/app-text/htp/Manifest
@@ -0,0 +1 @@
+DIST htp-1.16.tar.gz 141133 SHA256 905da83203be2d45d8bf0e454010ed73b78588dc65c0725b9ed712f01b7da8f2 SHA512 f33a9497fc3a1d0b95d8e3ee2747583d58626b565644e7c8cc054570458907aac9db42c6fa816b176b0e10db98ec7d1cedb521406035a8e7173e1abd991533a0 WHIRLPOOL 6b7d7da22fbd6768099fa333a897e4cf968becd565a41831f91fc033a74ac09ad0ada06c9fe1b26ca6bb742d61f61fe0c13c7a5da578f4db2b61fe66e37ceea8
diff --git a/app-text/htp/files/strip.patch b/app-text/htp/files/strip.patch
new file mode 100644
index 000000000000..9c92e757bc9e
--- /dev/null
+++ b/app-text/htp/files/strip.patch
@@ -0,0 +1,15 @@
+don't strip
+
+http://bugs.gentoo.org/240110
+
+--- src/Makefile
++++ src/Makefile
+@@ -33,7 +33,7 @@
+
+ install-bin: $(MAINEXE)
+ mkdir -p $(bindir)
+- $(INSTALL) -s $(MAINEXE) $(bindir)
++ $(INSTALL) $(MAINEXE) $(bindir)
+
+ #
+ # explicit dependency: final executable
diff --git a/app-text/htp/htp-1.16-r1.ebuild b/app-text/htp/htp-1.16-r1.ebuild
new file mode 100644
index 000000000000..ef44ec232413
--- /dev/null
+++ b/app-text/htp/htp-1.16-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An HTML preprocessor"
+HOMEPAGE="http://htp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+IUSE=""
+
+# HTP does not use autoconf, have to set options defined in Makefile.config
+
+src_prepare() {
+ epatch "${FILESDIR}"/strip.patch #240110
+ # let src_test take care of testing
+ sed -i -e '/SUBDIRS /s:tests::' Makefile || die
+ # don't install doc files with +x perms
+ sed -i -e '$aINSTALL += -m644' homepage/ref/{*/,}Makefile || die
+ # make src_test abort on failure
+ sed -i -e '/DIFF.*FAILED/s/echo/exit 1; :/' tests/Makefile || die
+ # the png file in this test isn't fetchable
+ sed -i -e 's: width="630" height="331"::' tests/png.html.exp || die
+}
+
+src_compile() {
+ emake \
+ CCOPT="-c ${CFLAGS} ${CPPFLAGS} -DHAVE_SNPRINTF -DHAVE_VASPRINTF -DHAVE_ASPRINTF" \
+ CC="$(tc-getCC)" \
+ LINK='$(CC) $(LDFLAGS)' \
+ || die
+}
+
+src_test() {
+ emake -C tests || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix='$(DESTDIR)/usr' \
+ pkgdocdir='$(DESTDIR)/usr/share/doc/${PF}/html' \
+ install || die
+}
diff --git a/app-text/htp/metadata.xml b/app-text/htp/metadata.xml
new file mode 100644
index 000000000000..5920e0eee87f
--- /dev/null
+++ b/app-text/htp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <upstream>
+ <remote-id type="sourceforge">htp</remote-id>
+ </upstream>
+</pkgmetadata>