summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 12:22:04 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:33 +0100
commit7bc6857c8bd23738d412b65711abb26e27c95458 (patch)
tree65aa2597903e7e4744923c707480cd1c2c0dfd2e /app-text/code2html
parentapp-text/bogosort: port to EAPI 7 (diff)
downloadgentoo-7bc6857c8bd23738d412b65711abb26e27c95458.tar.gz
gentoo-7bc6857c8bd23738d412b65711abb26e27c95458.tar.bz2
gentoo-7bc6857c8bd23738d412b65711abb26e27c95458.zip
app-text/code2html: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/code2html')
-rw-r--r--app-text/code2html/code2html-0.9.1-r2.ebuild25
-rw-r--r--app-text/code2html/files/code2html-0.9.1-prefix.patch4
-rw-r--r--app-text/code2html/files/code2html-0.9.1-scalar.patch4
3 files changed, 18 insertions, 15 deletions
diff --git a/app-text/code2html/code2html-0.9.1-r2.ebuild b/app-text/code2html/code2html-0.9.1-r2.ebuild
index 04b8d89521c5..37f32dd7a3c8 100644
--- a/app-text/code2html/code2html-0.9.1-r2.ebuild
+++ b/app-text/code2html/code2html-0.9.1-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch prefix
+inherit prefix
DESCRIPTION="Converts source files to colored HTML output"
HOMEPAGE="http://www.palfrader.org/code2html/"
@@ -13,27 +13,30 @@ SRC_URI="http://www.palfrader.org/code2html/all/${P}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-DEPEND=""
RDEPEND=">=dev-lang/perl-5"
-src_prepare() {
+PATCHES=(
# Be consistent in color codes (bug #119406)
- epatch "${WORKDIR}"/${P}-lowercase_color_codes.patch
+ "${WORKDIR}"/${P}-lowercase_color_codes.patch
# Improved C++ support (bug #133159)
- epatch "${WORKDIR}"/${P}-cpp_keywords.patch
+ "${WORKDIR}"/${P}-cpp_keywords.patch
# Improved Ada support (bug #133176)
- epatch "${WORKDIR}"/${P}-ada_identifiers.patch
+ "${WORKDIR}"/${P}-ada_identifiers.patch
# For prefix paths
- epatch "${FILESDIR}"/${P}-prefix.patch
- eprefixify code2html
+ "${FILESDIR}"/${P}-prefix.patch
# For newer Perl, bug 523610
- epatch "${FILESDIR}"/${P}-scalar.patch
+ "${FILESDIR}"/${P}-scalar.patch
+)
+
+src_prepare() {
+ default
+
+ eprefixify code2html
}
src_install() {
diff --git a/app-text/code2html/files/code2html-0.9.1-prefix.patch b/app-text/code2html/files/code2html-0.9.1-prefix.patch
index cc27296fb71c..fbfc9d6b5356 100644
--- a/app-text/code2html/files/code2html-0.9.1-prefix.patch
+++ b/app-text/code2html/files/code2html-0.9.1-prefix.patch
@@ -1,5 +1,5 @@
---- code2html
-+++ code2html
+--- a/code2html
++++ b/code2html
@@ -1,4 +1,4 @@
-#!/usr/bin/perl -w
+#!@GENTOO_PORTAGE_EPREFIX@/usr/bin/perl -w
diff --git a/app-text/code2html/files/code2html-0.9.1-scalar.patch b/app-text/code2html/files/code2html-0.9.1-scalar.patch
index eddc89a6a8f7..b8f56f1a7d1a 100644
--- a/app-text/code2html/files/code2html-0.9.1-scalar.patch
+++ b/app-text/code2html/files/code2html-0.9.1-scalar.patch
@@ -1,5 +1,5 @@
---- code2html.orig 2002-01-12 22:17:02.000000000 +0100
-+++ code2html 2014-09-24 13:52:52.000000000 +0200
+--- a/code2html
++++ b/code2html
@@ -1357,7 +1357,7 @@
my @lines = split ( /\n/, $_[0] );