summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-22 15:53:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-22 16:50:41 +0100
commit446e17088cc1b1f1758705072d412a40c3218c09 (patch)
tree455d63b63ba11d9149c640bccc503ad60c00761b /app-shells/loksh
parentnet-im/toxic: Stabilize 0.15.1 amd64, #944205 (diff)
downloadgentoo-446e17088cc1b1f1758705072d412a40c3218c09.tar.gz
gentoo-446e17088cc1b1f1758705072d412a40c3218c09.tar.bz2
gentoo-446e17088cc1b1f1758705072d412a40c3218c09.zip
app-shells/loksh: bump to 7.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/loksh')
-rw-r--r--app-shells/loksh/Manifest1
-rw-r--r--app-shells/loksh/loksh-7.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-shells/loksh/Manifest b/app-shells/loksh/Manifest
index 1a45f8f3d6d8..6bccee1fda19 100644
--- a/app-shells/loksh/Manifest
+++ b/app-shells/loksh/Manifest
@@ -1 +1,2 @@
DIST loksh-7.5.tar.xz 212104 BLAKE2B c5897860ca9ce7614921e890ec2ba6f464f600df9410082256e7b4cb53c15fbacb2f46fb8eada77910c19a260338f8e2fb55e3b324c96ab82e44f502859769a2 SHA512 9aee8219a4d63d06c95df2347611a04664ec344c2cb4c3d5d14bdea6b9cabc424246b0e070c901b4a5e38f5784b2c43f5c3c78b01f74cbdce46eded6fda043db
+DIST loksh-7.6.tar.xz 212080 BLAKE2B 845fbda4b0ff17c432a6ab2b506ad02bc2f9a36873d20ba3ab7b4bf5eeff6609f61c0223f9d18933314bca22b45c02313cdab6cb69bed73227918516b8be186a SHA512 c03a298e93bff3c689591a9864eeb5daa661b6b0b783102a271f7ebb08297a4939d8c923233fc23892b83c86d7102f9ae022f4b4d3fdf33e095e86690014fb24
diff --git a/app-shells/loksh/loksh-7.6.ebuild b/app-shells/loksh/loksh-7.6.ebuild
new file mode 100644
index 000000000000..587b3d778384
--- /dev/null
+++ b/app-shells/loksh/loksh-7.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/loksh/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+src_prepare() {
+ default
+ sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}