summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-28 16:20:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-28 17:04:46 +0100
commitd804f00db2b1043f76cfa2212f9b743d0bfc4d3b (patch)
tree1ed01da60aeac485bbf6e24953130a4e5bb01f18 /app-portage
parentdev-dotnet/gentoo-dotnet-maintainer-tools: bump to 3.0.0 (diff)
downloadgentoo-d804f00db2b1043f76cfa2212f9b743d0bfc4d3b.tar.gz
gentoo-d804f00db2b1043f76cfa2212f9b743d0bfc4d3b.tar.bz2
gentoo-d804f00db2b1043f76cfa2212f9b743d0bfc4d3b.zip
app-portage/elsw: bump to 1.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elsw/Manifest1
-rw-r--r--app-portage/elsw/elsw-1.0.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/elsw/Manifest b/app-portage/elsw/Manifest
index ac9e40b9cad3..f1eb82038ba7 100644
--- a/app-portage/elsw/Manifest
+++ b/app-portage/elsw/Manifest
@@ -1 +1,2 @@
DIST elsw-1.0.0.tar.gz 9793 BLAKE2B 63e61eebda9fde9d6f1eeabca917038308fc4c91464424cca167ce37c3c4beb6c2eb2f61673ddc1519acf38820ec4ad44b31d3246727a4d039b958e5d04222ee SHA512 a85a0b76b74335f2107e78a9e70f8f07a8af3543a021f3b1b9c63e64f7884888b43dbe387f6be12ee15dfa58a25102d1c3c63945d5cace3cdc8a7c612b65fc60
+DIST elsw-1.0.1.tar.gz 10171 BLAKE2B e4a8fe4f8008ea2d3f5b1ceebce83c86e487deaed21d7bc327f93b2c28cab506d8b9409b52cd55c0a9ac47b055e9a244535e9c865c965f42664d750f5e5d493f SHA512 478a79b7e260183f79b365cbbc28c3f1d764cc158c61cb82de7f7fb5888a90ad43dc8a2655abfbc09acf3427309011bb2570180a5531e8abbdf92b4bb0a7f50a
diff --git a/app-portage/elsw/elsw-1.0.1.ebuild b/app-portage/elsw/elsw-1.0.1.ebuild
new file mode 100644
index 000000000000..8979ed5fe4d6
--- /dev/null
+++ b/app-portage/elsw/elsw-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool providing a nice way to view the Portage world file"
+HOMEPAGE="https://gitlab.com/xgqt/python-elsw/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/xgqt/python-${PN}.git"
+else
+ inherit pypi
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.md )