summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-10 18:25:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-10 22:08:13 +0100
commitc0bcd73670383b192e589c2a3fa464e122f5bb50 (patch)
treed520b244cd1f590e231534309b64ce36d9f5fad7 /app-portage
parentdev-libs/ncnn: bdepend on protobuf[protoc(+)] (diff)
downloadgentoo-c0bcd73670383b192e589c2a3fa464e122f5bb50.tar.gz
gentoo-c0bcd73670383b192e589c2a3fa464e122f5bb50.tar.bz2
gentoo-c0bcd73670383b192e589c2a3fa464e122f5bb50.zip
app-portage/kuroo: Update deps, add optfeature, set ECM_TEST=true
Fix BDEPEND typo. Thanks-to: Andrew Schenck <galiven@users.sourceforge.net> Closes: https://bugs.gentoo.org/947748 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/kuroo/kuroo-9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-portage/kuroo/kuroo-9999.ebuild b/app-portage/kuroo/kuroo-9999.ebuild
index 2e6c55447465..6e7198c1e81c 100644
--- a/app-portage/kuroo/kuroo-9999.ebuild
+++ b/app-portage/kuroo/kuroo-9999.ebuild
@@ -1,19 +1,26 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+ECM_TEST="true"
KFMIN=6.6.0
QTMIN=6.7.2
-ESVN_REPO_URI="https://svn.code.sf.net/p/kuroo/code/kuroo4/trunk"
-inherit ecm subversion
+inherit ecm optfeature
+
+if [[ ${PV} == *9999* ]] ; then
+ ESVN_REPO_URI="https://svn.code.sf.net/p/kuroo/code/kuroo4/trunk"
+ inherit subversion
+else
+ SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Graphical Portage frontend based on KDE Frameworks"
HOMEPAGE="https://sourceforge.net/projects/kuroo/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE=""
DEPEND="
@@ -28,7 +35,6 @@ DEPEND="
>=kde-frameworks/ki18n-${KFMIN}:6
>=kde-frameworks/kio-${KFMIN}:6
>=kde-frameworks/kitemviews-${KFMIN}:6
- >=kde-frameworks/knotifications-${KFMIN}:6
>=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
>=kde-frameworks/ktextwidgets-${KFMIN}:6
>=kde-frameworks/kwidgetsaddons-${KFMIN}:6
@@ -37,15 +43,15 @@ DEPEND="
"
RDEPEND="${DEPEND}
app-portage/gentoolkit
- kde-misc/kdiff3
"
-BEDEPEND=">=dev-build/cmake-3.30.2"
+BDEPEND=">=dev-build/cmake-3.30.2"
pkg_postinst() {
if ! has_version app-admin/logrotate ; then
elog "Installing app-admin/logrotate is recommended to keep"
elog "portage's summary.log size reasonable to view in the history page."
fi
+ optfeature "graphical configuration merging (when run as root)" "kde-misc/kdiff3"
ecm_pkg_postinst
}