summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-14 08:26:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-14 08:26:50 +0200
commit4be00acabe21ad9862ea1c2535597408c175987a (patch)
treea0c622467ef37114a5a8f7568a57cf6c8f0b104f /app-portage/gemato
parentdev-python/numpy: Bump to 1.26.0_beta1 (diff)
downloadgentoo-4be00acabe21ad9862ea1c2535597408c175987a.tar.gz
gentoo-4be00acabe21ad9862ea1c2535597408c175987a.tar.bz2
gentoo-4be00acabe21ad9862ea1c2535597408c175987a.zip
app-portage/gemato: Bump to 20.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-20.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 979cb809f534..e1f907708393 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-20.4.tar.gz 88751 BLAKE2B e6b088e1b3e4de7525fcb2ce09bb7708ef8a8766a146f5cae8df7385aa879bb62d84893eb8f99a6025b717be809dfcf0876811cc5df296249cd7cb0534e0c186 SHA512 18a614827b8646b402bdcf3f57436e500a215876a6bb8ef41aab98bb35a5fc0be1b498c0eca1cbb9c78d35e4f3e2061414de06478f6489d052acf0ec41a0a313
+DIST gemato-20.5.tar.gz 88598 BLAKE2B dadbdd0275b6a79bb1c288d85ccb41600715c5e582b0d427a7fca5f08a8390200929b3de921bb7bd56f4a155fd9d979baaccb29a75c119c418c3ab62202f2856 SHA512 427e198b0630a18f219739dc093ddd0752a9b9871cd4ebf78b035c315bb49e4a5a639811d5fc26a17446c29eeea133e5cb97bb38fe89e2f74a6a320fd9bf5f0a
diff --git a/app-portage/gemato/gemato-20.5.ebuild b/app-portage/gemato/gemato-20.5.ebuild
new file mode 100644
index 000000000000..de40885edd5c
--- /dev/null
+++ b/app-portage/gemato/gemato-20.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}