summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-06-04 12:34:45 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-06-04 12:34:45 +0200
commit58e71948274b0119266597be72b352fbf3ea83f7 (patch)
tree5150903e1dd7dcda3a8a3c81e1ff5346aea75a55 /app-office
parentapp-office/scribus: added 1.6.9999 for testing purposes (diff)
downloadgentoo-58e71948274b0119266597be72b352fbf3ea83f7.tar.gz
gentoo-58e71948274b0119266597be72b352fbf3ea83f7.tar.bz2
gentoo-58e71948274b0119266597be72b352fbf3ea83f7.zip
app-office/scribus: fixed building with boost 1.85
Closes: https://bugs.gentoo.org/932492 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/files/scribus-1.6.1-boost-1.85-2.patch27
-rw-r--r--app-office/scribus/scribus-1.6.1-r1.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/app-office/scribus/files/scribus-1.6.1-boost-1.85-2.patch b/app-office/scribus/files/scribus-1.6.1-boost-1.85-2.patch
new file mode 100644
index 000000000000..55bc9934964b
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.6.1-boost-1.85-2.patch
@@ -0,0 +1,27 @@
+From 3116328e804c7366ec64c4224cbf20b0f14e52c8 Mon Sep 17 00:00:00 2001
+From: Jean Ghali <jghali@libertysurf.fr>
+Date: Sun, 31 Mar 2024 21:40:42 +0000
+Subject: [PATCH] Fix C++20 related warning "template-id is not allowed for
+ constructor in C++20"
+
+git-svn-id: svn://scribus.net/trunk/Scribus@26079 11d20701-8431-0410-a711-e3c959e3b870
+--- a/scribus/third_party/lib2geom/rect.h
++++ b/scribus/third_party/lib2geom/rect.h
+@@ -56,14 +56,14 @@ class D2<Interval> {
+ private:
+ Interval f[2];
+ public:
+- D2<Interval>() { f[X] = f[Y] = Interval(0, 0); }
++ D2() { f[X] = f[Y] = Interval(0, 0); }
+
+- D2<Interval>(Interval const &a, Interval const &b) {
++ D2(Interval const &a, Interval const &b) {
+ f[X] = a;
+ f[Y] = b;
+ }
+
+- D2<Interval>(Point const & a, Point const & b) {
++ D2(Point const & a, Point const & b) {
+ f[X] = Interval(a[X], b[X]);
+ f[Y] = Interval(a[Y], b[Y]);
+ }
diff --git a/app-office/scribus/scribus-1.6.1-r1.ebuild b/app-office/scribus/scribus-1.6.1-r1.ebuild
index e112af815030..3b20f7808237 100644
--- a/app-office/scribus/scribus-1.6.1-r1.ebuild
+++ b/app-office/scribus/scribus-1.6.1-r1.ebuild
@@ -79,6 +79,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.6.1-poppler-24.03.patch
"${FILESDIR}"/${PN}-1.6.1-poppler-24.05.patch
"${FILESDIR}"/${PN}-1.6.1-boost-1.85.patch
+ "${FILESDIR}"/${PN}-1.6.1-boost-1.85-2.patch
)
src_prepare() {