summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /app-misc
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/anki/anki-24.06.3-r2.ebuild (renamed from app-misc/anki/anki-24.06.3-r1.ebuild)2
-rw-r--r--app-misc/battop/battop-0.2.4_p1-r1.ebuild (renamed from app-misc/battop/battop-0.2.4_p1.ebuild)2
-rw-r--r--app-misc/broot/broot-1.39.1-r1.ebuild (renamed from app-misc/broot/broot-1.39.1.ebuild)1
-rw-r--r--app-misc/broot/broot-1.40.0-r1.ebuild (renamed from app-misc/broot/broot-1.40.0.ebuild)1
-rw-r--r--app-misc/broot/broot-1.41.1-r1.ebuild (renamed from app-misc/broot/broot-1.41.1.ebuild)1
-rw-r--r--app-misc/broot/broot-1.42.0-r1.ebuild (renamed from app-misc/broot/broot-1.42.0.ebuild)2
-rw-r--r--app-misc/jaq/jaq-1.4.0-r1.ebuild (renamed from app-misc/jaq/jaq-1.4.0.ebuild)4
-rw-r--r--app-misc/jaq/jaq-1.5.0-r1.ebuild (renamed from app-misc/jaq/jaq-1.5.0.ebuild)4
-rw-r--r--app-misc/jaq/jaq-1.6.0-r1.ebuild (renamed from app-misc/jaq/jaq-1.6.0.ebuild)4
-rw-r--r--app-misc/jf/jf-0.6.2-r2.ebuild (renamed from app-misc/jf/jf-0.6.2-r1.ebuild)2
-rw-r--r--app-misc/rpick/rpick-0.9.1-r1.ebuild (renamed from app-misc/rpick/rpick-0.9.1.ebuild)0
-rw-r--r--app-misc/skim/skim-0.10.4-r1.ebuild (renamed from app-misc/skim/skim-0.10.4.ebuild)0
-rw-r--r--app-misc/tzupdate/tzupdate-3.1.0-r1.ebuild (renamed from app-misc/tzupdate/tzupdate-3.1.0.ebuild)0
-rw-r--r--app-misc/weggli/metadata.xml2
-rw-r--r--app-misc/weggli/weggli-0.2.4-r1.ebuild142
-rw-r--r--app-misc/weggli/weggli-0.2.4.ebuild141
-rw-r--r--app-misc/zellij/zellij-0.41.1-r1.ebuild (renamed from app-misc/zellij/zellij-0.41.1.ebuild)0
17 files changed, 147 insertions, 161 deletions
diff --git a/app-misc/anki/anki-24.06.3-r1.ebuild b/app-misc/anki/anki-24.06.3-r2.ebuild
index 19438db1f49e..dea830f2ea71 100644
--- a/app-misc/anki/anki-24.06.3-r1.ebuild
+++ b/app-misc/anki/anki-24.06.3-r2.ebuild
@@ -774,7 +774,6 @@ BDEPEND="
>=app-arch/zstd-1.5.5:=
dev-libs/protobuf
virtual/pkgconfig
- >=virtual/rust-1.75.0
doc? (
$(python_gen_cond_dep '
>=dev-python/sphinx-7.2.6[${PYTHON_USEDEP}]
@@ -827,6 +826,7 @@ pkg_setup() {
fi
fi
fi
+ rust_pkg_setup
}
src_prepare() {
diff --git a/app-misc/battop/battop-0.2.4_p1.ebuild b/app-misc/battop/battop-0.2.4_p1-r1.ebuild
index fc2e2043620b..330c3c977e1c 100644
--- a/app-misc/battop/battop-0.2.4_p1.ebuild
+++ b/app-misc/battop/battop-0.2.4_p1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Autogenerated by pycargoebuild 0.12.1
diff --git a/app-misc/broot/broot-1.39.1.ebuild b/app-misc/broot/broot-1.39.1-r1.ebuild
index 69a4effdf7ac..f50fb99c83a9 100644
--- a/app-misc/broot/broot-1.39.1.ebuild
+++ b/app-misc/broot/broot-1.39.1-r1.ebuild
@@ -343,7 +343,6 @@ RDEPEND="
X? ( x11-libs/libxcb:= )
"
DEPEND="${RDEPEND}"
-BDEPEND=">=virtual/rust-1.65"
QA_FLAGS_IGNORED="usr/bin/${PN}"
diff --git a/app-misc/broot/broot-1.40.0.ebuild b/app-misc/broot/broot-1.40.0-r1.ebuild
index 69a4effdf7ac..f50fb99c83a9 100644
--- a/app-misc/broot/broot-1.40.0.ebuild
+++ b/app-misc/broot/broot-1.40.0-r1.ebuild
@@ -343,7 +343,6 @@ RDEPEND="
X? ( x11-libs/libxcb:= )
"
DEPEND="${RDEPEND}"
-BDEPEND=">=virtual/rust-1.65"
QA_FLAGS_IGNORED="usr/bin/${PN}"
diff --git a/app-misc/broot/broot-1.41.1.ebuild b/app-misc/broot/broot-1.41.1-r1.ebuild
index cf8bfec8f22d..2379a151314b 100644
--- a/app-misc/broot/broot-1.41.1.ebuild
+++ b/app-misc/broot/broot-1.41.1-r1.ebuild
@@ -343,7 +343,6 @@ RDEPEND="
X? ( x11-libs/libxcb:= )
"
DEPEND="${RDEPEND}"
-BDEPEND=">=virtual/rust-1.76"
QA_FLAGS_IGNORED="usr/bin/${PN}"
diff --git a/app-misc/broot/broot-1.42.0.ebuild b/app-misc/broot/broot-1.42.0-r1.ebuild
index ec4dd63e7847..15532af1196f 100644
--- a/app-misc/broot/broot-1.42.0.ebuild
+++ b/app-misc/broot/broot-1.42.0-r1.ebuild
@@ -330,6 +330,7 @@ zerocopy-derive@0.7.35
zune-inflate@0.2.54
"
+RUST_MIN_VER="1.77.1"
inherit bash-completion-r1 cargo
DESCRIPTION="A new way to see and navigate directory trees"
@@ -348,7 +349,6 @@ RDEPEND="
X? ( x11-libs/libxcb:= )
"
DEPEND="${RDEPEND}"
-BDEPEND=">=virtual/rust-1.76"
QA_FLAGS_IGNORED="usr/bin/${PN}"
diff --git a/app-misc/jaq/jaq-1.4.0.ebuild b/app-misc/jaq/jaq-1.4.0-r1.ebuild
index 3ab923ebfc7a..47621a72b4a6 100644
--- a/app-misc/jaq/jaq-1.4.0.ebuild
+++ b/app-misc/jaq/jaq-1.4.0-r1.ebuild
@@ -104,10 +104,6 @@ LICENSE+="
SLOT="0"
KEYWORDS="~amd64"
-BDEPEND="
- >=virtual/rust-1.64
-"
-
QA_FLAGS_IGNORED="usr/bin/jaq"
QA_PRESTRIPPED="usr/bin/jaq"
diff --git a/app-misc/jaq/jaq-1.5.0.ebuild b/app-misc/jaq/jaq-1.5.0-r1.ebuild
index 84cd770b0588..0ed97bf85a63 100644
--- a/app-misc/jaq/jaq-1.5.0.ebuild
+++ b/app-misc/jaq/jaq-1.5.0-r1.ebuild
@@ -103,10 +103,6 @@ LICENSE+="
SLOT="0"
KEYWORDS="~amd64"
-BDEPEND="
- >=virtual/rust-1.64
-"
-
QA_FLAGS_IGNORED="usr/bin/jaq"
QA_PRESTRIPPED="usr/bin/jaq"
diff --git a/app-misc/jaq/jaq-1.6.0.ebuild b/app-misc/jaq/jaq-1.6.0-r1.ebuild
index 5be92024ab2c..911945462c9e 100644
--- a/app-misc/jaq/jaq-1.6.0.ebuild
+++ b/app-misc/jaq/jaq-1.6.0-r1.ebuild
@@ -100,10 +100,6 @@ LICENSE+="
SLOT="0"
KEYWORDS="~amd64"
-BDEPEND="
- >=virtual/rust-1.64
-"
-
QA_FLAGS_IGNORED="usr/bin/jaq"
QA_PRESTRIPPED="usr/bin/jaq"
diff --git a/app-misc/jf/jf-0.6.2-r1.ebuild b/app-misc/jf/jf-0.6.2-r2.ebuild
index cf3416531097..849e01ee7f1a 100644
--- a/app-misc/jf/jf-0.6.2-r1.ebuild
+++ b/app-misc/jf/jf-0.6.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Autogenerated by pycargoebuild 0.10
diff --git a/app-misc/rpick/rpick-0.9.1.ebuild b/app-misc/rpick/rpick-0.9.1-r1.ebuild
index 064cbbda8ef7..064cbbda8ef7 100644
--- a/app-misc/rpick/rpick-0.9.1.ebuild
+++ b/app-misc/rpick/rpick-0.9.1-r1.ebuild
diff --git a/app-misc/skim/skim-0.10.4.ebuild b/app-misc/skim/skim-0.10.4-r1.ebuild
index 3ffb2711ab1e..3ffb2711ab1e 100644
--- a/app-misc/skim/skim-0.10.4.ebuild
+++ b/app-misc/skim/skim-0.10.4-r1.ebuild
diff --git a/app-misc/tzupdate/tzupdate-3.1.0.ebuild b/app-misc/tzupdate/tzupdate-3.1.0-r1.ebuild
index 1143edfba7dc..1143edfba7dc 100644
--- a/app-misc/tzupdate/tzupdate-3.1.0.ebuild
+++ b/app-misc/tzupdate/tzupdate-3.1.0-r1.ebuild
diff --git a/app-misc/weggli/metadata.xml b/app-misc/weggli/metadata.xml
index 8e6ae4d7b0c1..749e1a60957a 100644
--- a/app-misc/weggli/metadata.xml
+++ b/app-misc/weggli/metadata.xml
@@ -6,6 +6,6 @@
<name>Matthew Smith</name>
</maintainer>
<upstream>
- <remote-id type="github">googleprojectzero/weggli</remote-id>
+ <remote-id type="github">weggli-rs/weggli</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-misc/weggli/weggli-0.2.4-r1.ebuild b/app-misc/weggli/weggli-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..cf0b3be9e3bb
--- /dev/null
+++ b/app-misc/weggli/weggli-0.2.4-r1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ aho-corasick@0.7.18
+ ansi_term@0.12.1
+ assert_cmd@2.0.2
+ atty@0.2.14
+ autocfg@1.0.1
+ bitflags@1.3.2
+ bstr@0.2.17
+ bumpalo@3.9.1
+ cast@0.2.7
+ cc@1.0.72
+ cfg-if@0.1.10
+ cfg-if@1.0.0
+ chrono@0.4.19
+ clap@2.34.0
+ colored@2.0.0
+ criterion@0.3.5
+ criterion-plot@0.4.4
+ crossbeam-channel@0.5.2
+ crossbeam-deque@0.8.1
+ crossbeam-epoch@0.9.6
+ crossbeam-utils@0.8.6
+ csv@1.1.6
+ csv-core@0.1.10
+ ctor@0.1.21
+ difference@2.0.0
+ difflib@0.4.0
+ doc-comment@0.3.3
+ either@1.6.1
+ float-cmp@0.8.0
+ ghost@0.1.2
+ half@1.8.2
+ hermit-abi@0.1.19
+ indoc@0.3.6
+ indoc-impl@0.3.6
+ instant@0.1.12
+ inventory@0.1.11
+ inventory-impl@0.1.11
+ itertools@0.10.3
+ itoa@0.4.8
+ itoa@1.0.1
+ js-sys@0.3.55
+ lazy_static@1.4.0
+ libc@0.2.112
+ lock_api@0.4.5
+ log@0.4.14
+ memchr@2.4.1
+ memoffset@0.6.5
+ nix@0.17.0
+ normalize-line-endings@0.3.0
+ num-integer@0.1.44
+ num-traits@0.2.14
+ num_cpus@1.13.1
+ oorandom@11.1.3
+ parking_lot@0.11.2
+ parking_lot_core@0.8.5
+ paste@0.1.18
+ paste-impl@0.1.18
+ plotters@0.3.1
+ plotters-backend@0.3.2
+ plotters-svg@0.3.1
+ predicates@1.0.8
+ predicates@2.1.0
+ predicates-core@1.0.2
+ predicates-tree@1.0.4
+ proc-macro-hack@0.5.19
+ proc-macro2@1.0.36
+ pyo3@0.13.2
+ pyo3-macros@0.13.2
+ pyo3-macros-backend@0.13.2
+ quote@1.0.14
+ rayon@1.5.1
+ rayon-core@1.9.1
+ redox_syscall@0.2.10
+ regex@1.5.4
+ regex-automata@0.1.10
+ regex-syntax@0.6.25
+ rustc-hash@1.1.0
+ rustc_version@0.4.0
+ ryu@1.0.9
+ same-file@1.0.6
+ scopeguard@1.1.0
+ semver@1.0.4
+ serde@1.0.133
+ serde_cbor@0.11.2
+ serde_derive@1.0.133
+ serde_json@1.0.74
+ simplelog@0.10.2
+ smallvec@1.7.0
+ strsim@0.8.0
+ syn@1.0.85
+ termcolor@1.1.2
+ termtree@0.2.4
+ textwrap@0.11.0
+ time@0.1.44
+ tinytemplate@1.2.1
+ tree-sitter@0.20.2
+ unicode-width@0.1.9
+ unicode-xid@0.2.2
+ unindent@0.1.7
+ vec_map@0.8.2
+ void@1.0.2
+ wait-timeout@0.2.0
+ walkdir@2.3.2
+ wasi@0.10.0+wasi-snapshot-preview1
+ wasm-bindgen@0.2.78
+ wasm-bindgen-backend@0.2.78
+ wasm-bindgen-macro@0.2.78
+ wasm-bindgen-macro-support@0.2.78
+ wasm-bindgen-shared@0.2.78
+ web-sys@0.3.55
+ winapi@0.3.9
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-util@0.1.5
+ winapi-x86_64-pc-windows-gnu@0.4.0
+"
+
+# We can inherit distutils-r1 here and build the Python
+# module. Unfortunately the Python module seems to not include the
+# tree-sitter grammar. Patching the .so to need the system's
+# libtree-sitter-cpp seems to work, but it is not correct because the
+# weggli grammar has some minor modifications.
+
+inherit cargo
+
+DESCRIPTION="a fast and robust semantic search tool for C and C++ codebases"
+HOMEPAGE="https://github.com/weggli-rs/weggli"
+SRC_URI="
+ https://github.com/weggli-rs/weggli/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+
+LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
diff --git a/app-misc/weggli/weggli-0.2.4.ebuild b/app-misc/weggli/weggli-0.2.4.ebuild
deleted file mode 100644
index f4580b114190..000000000000
--- a/app-misc/weggli/weggli-0.2.4.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CRATES="
- aho-corasick-0.7.18
- ansi_term-0.12.1
- assert_cmd-2.0.2
- atty-0.2.14
- autocfg-1.0.1
- bitflags-1.3.2
- bstr-0.2.17
- bumpalo-3.9.1
- cast-0.2.7
- cc-1.0.72
- cfg-if-0.1.10
- cfg-if-1.0.0
- chrono-0.4.19
- clap-2.34.0
- colored-2.0.0
- criterion-0.3.5
- criterion-plot-0.4.4
- crossbeam-channel-0.5.2
- crossbeam-deque-0.8.1
- crossbeam-epoch-0.9.6
- crossbeam-utils-0.8.6
- csv-1.1.6
- csv-core-0.1.10
- ctor-0.1.21
- difference-2.0.0
- difflib-0.4.0
- doc-comment-0.3.3
- either-1.6.1
- float-cmp-0.8.0
- ghost-0.1.2
- half-1.8.2
- hermit-abi-0.1.19
- indoc-0.3.6
- indoc-impl-0.3.6
- instant-0.1.12
- inventory-0.1.11
- inventory-impl-0.1.11
- itertools-0.10.3
- itoa-0.4.8
- itoa-1.0.1
- js-sys-0.3.55
- lazy_static-1.4.0
- libc-0.2.112
- lock_api-0.4.5
- log-0.4.14
- memchr-2.4.1
- memoffset-0.6.5
- nix-0.17.0
- normalize-line-endings-0.3.0
- num-integer-0.1.44
- num-traits-0.2.14
- num_cpus-1.13.1
- oorandom-11.1.3
- parking_lot-0.11.2
- parking_lot_core-0.8.5
- paste-0.1.18
- paste-impl-0.1.18
- plotters-0.3.1
- plotters-backend-0.3.2
- plotters-svg-0.3.1
- predicates-1.0.8
- predicates-2.1.0
- predicates-core-1.0.2
- predicates-tree-1.0.4
- proc-macro-hack-0.5.19
- proc-macro2-1.0.36
- pyo3-0.13.2
- pyo3-macros-0.13.2
- pyo3-macros-backend-0.13.2
- quote-1.0.14
- rayon-1.5.1
- rayon-core-1.9.1
- redox_syscall-0.2.10
- regex-1.5.4
- regex-automata-0.1.10
- regex-syntax-0.6.25
- rustc-hash-1.1.0
- rustc_version-0.4.0
- ryu-1.0.9
- same-file-1.0.6
- scopeguard-1.1.0
- semver-1.0.4
- serde-1.0.133
- serde_cbor-0.11.2
- serde_derive-1.0.133
- serde_json-1.0.74
- simplelog-0.10.2
- smallvec-1.7.0
- strsim-0.8.0
- syn-1.0.85
- termcolor-1.1.2
- termtree-0.2.4
- textwrap-0.11.0
- time-0.1.44
- tinytemplate-1.2.1
- tree-sitter-0.20.2
- unicode-width-0.1.9
- unicode-xid-0.2.2
- unindent-0.1.7
- vec_map-0.8.2
- void-1.0.2
- wait-timeout-0.2.0
- walkdir-2.3.2
- wasi-0.10.0+wasi-snapshot-preview1
- wasm-bindgen-0.2.78
- wasm-bindgen-backend-0.2.78
- wasm-bindgen-macro-0.2.78
- wasm-bindgen-macro-support-0.2.78
- wasm-bindgen-shared-0.2.78
- web-sys-0.3.55
- winapi-0.3.9
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-util-0.1.5
- winapi-x86_64-pc-windows-gnu-0.4.0
-"
-
-# We can inherit distutils-r1 here and build the Python
-# module. Unfortunately the Python module seems to not include the
-# tree-sitter grammar. Patching the .so to need the system's
-# libtree-sitter-cpp seems to work, but it is not correct because the
-# weggli grammar has some minor modifications.
-inherit cargo
-
-DESCRIPTION="a fast and robust semantic search tool for C and C++ codebases"
-HOMEPAGE="https://github.com/googleprojectzero/weggli"
-SRC_URI="
- https://github.com/googleprojectzero/weggli/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris)
-"
-
-LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 MIT MPL-2.0 Unlicense"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-QA_FLAGS_IGNORED="usr/bin/${PN}"
diff --git a/app-misc/zellij/zellij-0.41.1.ebuild b/app-misc/zellij/zellij-0.41.1-r1.ebuild
index cc15a6b9910d..cc15a6b9910d 100644
--- a/app-misc/zellij/zellij-0.41.1.ebuild
+++ b/app-misc/zellij/zellij-0.41.1-r1.ebuild