summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/vifm/vifm-0.7.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/vifm/vifm-0.7.2.ebuild')
-rw-r--r--app-misc/vifm/vifm-0.7.2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/vifm/vifm-0.7.2.ebuild b/app-misc/vifm/vifm-0.7.2.ebuild
new file mode 100644
index 000000000000..c3b4be3ccddc
--- /dev/null
+++ b/app-misc/vifm/vifm-0.7.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="Console file manager with vi(m)-like keybindings"
+HOMEPAGE="http://vifm.info/"
+SRC_URI="mirror://sourceforge/vifm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc s390 x86"
+IUSE="+compatibility +extended-keys +magic vim-plugin vim-syntax"
+
+DEPEND="
+ >=sys-libs/ncurses-5.7-r7
+ magic? ( sys-apps/file )
+"
+RDEPEND="
+ ${DEPEND}
+ vim-plugin? ( >=app-editors/vim-7.3 )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+
+DOCS=( AUTHORS FAQ NEWS README TODO )
+
+S="${WORKDIR}"
+
+src_configure() {
+ econf \
+ $(use_enable compatibility compatibility-mode) \
+ $(use_enable extended-keys) \
+ $(use_with magic libmagic)
+}
+
+src_install() {
+ base_src_install
+
+ if use vim-syntax; then
+ local t
+ for t in ftdetect ftplugin syntax; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/data/vim/"${t}"/"${PN}".vim
+ done
+ fi
+ if use vim-plugin; then
+ local t
+ for t in doc plugin; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/data/vim/"${t}"/"${PN}".*
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "To use vim to view the vifm help, copy /usr/share/${P}/vifm.txt"
+ elog " to ~/.vim/doc/ and run ':helptags ~/.vim/doc' in vim,"
+ elog "then edit ~/.vifm/vifmrc${PV/a/} and set USE_VIM_HELP=1"
+ elog ""
+ elog "To use the vifm plugin in vim, copy /usr/share/${P}/vifm.vim to"
+ elog " /usr/share/vim/vimXX/"
+}