summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-27 08:02:27 +0000
committerSam James <sam@gentoo.org>2023-01-27 08:03:12 +0000
commitea8bb5a7148f014756a13b1acebdfe57700fe30d (patch)
tree1ea4304449d2f7f2673a88646de9da564365952f /app-misc/rdfind/files
parentdev-libs/crossguid: add 0.2.2_p20190529 (diff)
downloadgentoo-ea8bb5a7148f014756a13b1acebdfe57700fe30d.tar.gz
gentoo-ea8bb5a7148f014756a13b1acebdfe57700fe30d.tar.bz2
gentoo-ea8bb5a7148f014756a13b1acebdfe57700fe30d.zip
app-misc/rdfind: fix build w/ gcc 13, fix configure check
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/rdfind/files')
-rw-r--r--app-misc/rdfind/files/rdfind-1.5.0-configure-nettle.patch23
-rw-r--r--app-misc/rdfind/files/rdfind-1.5.0-gcc-13.patch35
2 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/rdfind/files/rdfind-1.5.0-configure-nettle.patch b/app-misc/rdfind/files/rdfind-1.5.0-configure-nettle.patch
new file mode 100644
index 000000000000..d95fde911a00
--- /dev/null
+++ b/app-misc/rdfind/files/rdfind-1.5.0-configure-nettle.patch
@@ -0,0 +1,23 @@
+https://github.com/pauldreik/rdfind/pull/115
+
+From 823a4deb61f6f9b91b0cfc4a7e7b20922c635777 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 1 Sep 2022 13:13:50 -0700
+Subject: [PATCH] configure: Fix check for AC_CHECK_LIB
+
+Check for nettle_pbkdf2_hmac_sha256 from libnettle instead of main()
+which is not in nettle library
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/configure.ac
++++ b/configure.ac
+@@ -46,7 +46,7 @@ AC_CHECK_HEADER(nettle/sha.h,,[AC_MSG_ERROR([
+ On Debian-ish systems, use "apt-get install nettle-dev" to get a system
+ wide nettle install.
+ ])])
+-AC_CHECK_LIB(nettle,main,,[AC_MSG_ERROR([
++AC_CHECK_LIB(nettle,nettle_pbkdf2_hmac_sha256,,[AC_MSG_ERROR([
+ Could not link to libnettle. Please install nettle
+ first. If you have already done so; please run ldconfig
+ as root or check whether the path libnettle was installed
+
diff --git a/app-misc/rdfind/files/rdfind-1.5.0-gcc-13.patch b/app-misc/rdfind/files/rdfind-1.5.0-gcc-13.patch
new file mode 100644
index 000000000000..1597b89d7119
--- /dev/null
+++ b/app-misc/rdfind/files/rdfind-1.5.0-gcc-13.patch
@@ -0,0 +1,35 @@
+https://github.com/pauldreik/rdfind/pull/129
+
+(drop limits bit as we already had a patch for that)
+
+From 8c317f0fd5fde95a9aae2319053a196a166aec88 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 25 Jan 2023 21:12:47 -0800
+Subject: [PATCH] include standard headers <limits> and <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint> is no longer
+transitively included [1]. Explicitly include it for uint64_t.
+
+Fixes errors like below
+
+../rdfind-1.5.0/rdfind.cc:225:30: error: 'numeric_limits' is not a member of 'std'
+ 225 | o.maximumfilesize = std::numeric_limits<decltype(o.maximumfilesize)>::max();
+ | ^~~~~~~~~~~~~~
+
+...
+
+| ../rdfind-1.5.0/Fileinfo.hh:70:20: error: 'std::int64_t' has not been declared
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/Fileinfo.hh
++++ b/Fileinfo.hh
+@@ -8,6 +8,7 @@
+ #define Fileinfo_hh
+
+ #include <array>
++#include <cstdint>
+ #include <string>
+
+ // os specific headers