summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 19:05:14 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:05:55 +0300
commitd77c73a1bfc8bb3a5a5b7bcbb02856dc87d92bcc (patch)
tree752f1c528b01f954f076f02d18d06d066d9b83e2 /app-misc/qtxdg-tools/qtxdg-tools-3.11.0.ebuild
parentlxqt-base/lxqt-runner: add 1.3.0 (diff)
downloadgentoo-d77c73a1bfc8bb3a5a5b7bcbb02856dc87d92bcc.tar.gz
gentoo-d77c73a1bfc8bb3a5a5b7bcbb02856dc87d92bcc.tar.bz2
gentoo-d77c73a1bfc8bb3a5a5b7bcbb02856dc87d92bcc.zip
app-misc/qtxdg-tools: add 3.11.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'app-misc/qtxdg-tools/qtxdg-tools-3.11.0.ebuild')
-rw-r--r--app-misc/qtxdg-tools/qtxdg-tools-3.11.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/qtxdg-tools/qtxdg-tools-3.11.0.ebuild b/app-misc/qtxdg-tools/qtxdg-tools-3.11.0.ebuild
new file mode 100644
index 000000000000..a648456e7b5e
--- /dev/null
+++ b/app-misc/qtxdg-tools/qtxdg-tools-3.11.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="User Tools from libqtxdg"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
+RDEPEND="
+ >=dev-libs/libqtxdg-3.11.0
+ >=dev-qt/qtcore-5.15:5
+"
+DEPEND="${RDEPEND}"