summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-11-13 18:59:58 +0000
committerDavid Seifert <soap@gentoo.org>2016-11-14 18:30:37 +0100
commitd44ab9543f5a072f862a30fad91a1fd5021acd82 (patch)
tree5a29ce195e38d586c36574d70220c7204d56af64 /app-misc/ddcutil
parentapp-misc/ddctool: remove old version 0.5.0 (diff)
downloadgentoo-d44ab9543f5a072f862a30fad91a1fd5021acd82.tar.gz
gentoo-d44ab9543f5a072f862a30fad91a1fd5021acd82.tar.bz2
gentoo-d44ab9543f5a072f862a30fad91a1fd5021acd82.zip
app-misc/ddcutil: Renamed from ddctool, bump to 0.6.0
This release strictly dealt with changing the name with no new bug fixes or features. Reason for rename from upstream: As of release 0.6, the name of this program is changing from ddctool to ddcutil to avoid confusion with a commerical datacenter program also named ddctool. Signed off by: Jonathan Scruggs (j.scruggs@gmail.com. irc: Dracwyrm) Closes: https://github.com/gentoo/gentoo/pull/2830 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/ddcutil')
-rw-r--r--app-misc/ddcutil/Manifest1
-rw-r--r--app-misc/ddcutil/ddcutil-0.6.0.ebuild102
-rw-r--r--app-misc/ddcutil/metadata.xml32
3 files changed, 135 insertions, 0 deletions
diff --git a/app-misc/ddcutil/Manifest b/app-misc/ddcutil/Manifest
new file mode 100644
index 000000000000..c224ff23bbdb
--- /dev/null
+++ b/app-misc/ddcutil/Manifest
@@ -0,0 +1 @@
+DIST ddcutil-0.6.0.tar.gz 323380 SHA256 ae435699578297cdb40006471e046576e825d971c6c867822568660d815e966a SHA512 ab5882c22e7cbf17f8513a80443a25b2d1698e45b2fd3bf6f163fd86691808a5244830da2664b882ddc6592a9228afbd9f4c8f6821115167fd28b114c986e172 WHIRLPOOL 37a334a0075b08f0b6e01cc721d414aedb9e06f36fc295698662616c5fbf98ca4c256eba91344748409766fa9139173335d14b8243bc0ee7404c2914a10b38c6
diff --git a/app-misc/ddcutil/ddcutil-0.6.0.ebuild b/app-misc/ddcutil/ddcutil-0.6.0.ebuild
new file mode 100644
index 000000000000..ea8f6f047755
--- /dev/null
+++ b/app-misc/ddcutil/ddcutil-0.6.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools linux-info udev user
+
+DESCRIPTION="Program for querying and changing monitor settings"
+HOMEPAGE="http://www.ddcutil.com/"
+
+SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# Binary drivers need special instructions compared to the open source counterparts.
+# If a user switches drivers, they will need to set different use flags for
+# Xorg or Wayland or Mesa, so this will trigger the rebuild against
+# the different drivers.
+IUSE="usb-monitor user-permissions video_cards_fglrx video_cards_nvidia"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libX11
+ dev-libs/glib
+ sys-apps/i2c-tools
+ virtual/udev
+ usb-monitor? (
+ dev-libs/hidapi
+ virtual/libusb:1
+ sys-apps/usbutils )"
+DEPEND="video_cards_fglrx? ( x11-libs/amd-adl-sdk )
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+pkg_pretend() {
+ # This program needs /dev/ic2-* devices to communicate with the monitor.
+ CONFIG_CHECK="~I2C_CHARDEV"
+ ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
+ if use usb-monitor; then
+ CONFIG_CHECK+="~HIDRAW ~USB_HIDDEV"
+ ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
+ ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
+ fi
+
+ # Now do the actual checks setup above
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(usex video_cards_fglrx "--with-adl-headers=/usr/include/ADL" "")
+ $(use_enable usb-monitor usb)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ if use user-permissions; then
+ udev_dorules data/etc/udev/rules.d/45-ddcutil-i2c.rules
+ if use usb-monitor; then
+ udev_dorules data/etc/udev/rules.d/45-ddcutil-usb.rules
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use user-permissions; then
+ enewgroup i2c
+ einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
+ einfo "users to the i2c group: usermod -aG i2c user"
+ einfo "Restart the computer or reload the i2c-dev module to activate"
+ einfo "the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
+
+ if use usb-monitor; then
+ enewgroup video
+ einfo "To allow non-root users access to USB monitors, add those users"
+ einfo "to the video group: usermod -aG video user"
+ einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
+ einfo "the monitor to activate the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/usb/"
+ fi
+
+ udev_reload
+ fi
+
+ if use video_cards_nvidia; then
+ einfo "=================================================================="
+ einfo "Please read the following webpage on proper usage with the nVidia "
+ einfo "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
+ einfo "=================================================================="
+ fi
+}
diff --git a/app-misc/ddcutil/metadata.xml b/app-misc/ddcutil/metadata.xml
new file mode 100644
index 000000000000..6d0486ba8ad6
--- /dev/null
+++ b/app-misc/ddcutil/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>j.scruggs@gmail.com</email>
+ <name>Jonathan Scruggs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ ddcutil primarily uses DDC/CI (Display Data Channel Command Interface)
+ to communicate with monitors implementing MCCS (Monitor Control Command
+ Set) over I2C. Normally, the video driver for the monitor exposes the
+ I2C channel as devices named /dev/i2c-n. Alternatively, there is initial
+ support for monitors (such as Apple displays) that implement MCCS using
+ a USB connection.
+ </longdescription>
+
+ <use>
+ <flag name="user-permissions">
+ Adds a udev rules to allow non-root users in the i2c group to
+ access the /dev/i2c-* devices. If usb-monitor is selected, users
+ will need to be added to the video group to access the USB monitor.
+ Otherwise, only root will be able to use ddcutil.
+ </flag>
+ <flag name="usb-monitor">
+ Adds support for monitors attached via USB.
+ </flag>
+ </use>
+</pkgmetadata>