summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-07-07 00:11:56 +0200
committerMike Gilbert <floppym@gentoo.org>2018-07-06 22:02:58 -0400
commitd9121c3a8f0bd4ae654559a369f27da110ff0de8 (patch)
tree98b203c99bac6be69ee6d17d14bab3d23d6fbb15 /app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild
parentapp-i18n/*fcitx*, app-i18n/mozc: Update URIs. (diff)
downloadgentoo-d9121c3a8f0bd4ae654559a369f27da110ff0de8.tar.gz
gentoo-d9121c3a8f0bd4ae654559a369f27da110ff0de8.tar.bz2
gentoo-d9121c3a8f0bd4ae654559a369f27da110ff0de8.zip
app-i18n/fcitx-qt5: Version bump (1.2.3).
Diffstat (limited to 'app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild')
-rw-r--r--app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild
new file mode 100644
index 000000000000..2c54b501abd1
--- /dev/null
+++ b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-qt5.git"
+fi
+
+DESCRIPTION="Fcitx input method module for Qt 5"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-qt5"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="BSD GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ~hppa ppc ppc64 x86"
+IUSE=""
+
+# Private headers of dev-qt/qtgui:5 used.
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ virtual/libintl
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ kde-frameworks/extra-cmake-modules:5
+ virtual/pkgconfig"
+
+DOCS=()