summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-17 13:25:07 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-17 13:25:07 +0200
commite74a25b9076f92e07b2a80357bb6f2185751dbe2 (patch)
tree4267b46c9aa5f018bde86451d2d0d7996d10b688 /app-i18n/anthy/anthy-9100h-r3.ebuild
parentdev-lang/gforth: drop old (diff)
downloadgentoo-e74a25b9076f92e07b2a80357bb6f2185751dbe2.tar.gz
gentoo-e74a25b9076f92e07b2a80357bb6f2185751dbe2.tar.bz2
gentoo-e74a25b9076f92e07b2a80357bb6f2185751dbe2.zip
app-i18n/anthy: Remove references to app-dicts/canna-2ch
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-i18n/anthy/anthy-9100h-r3.ebuild')
-rw-r--r--app-i18n/anthy/anthy-9100h-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-i18n/anthy/anthy-9100h-r3.ebuild b/app-i18n/anthy/anthy-9100h-r3.ebuild
new file mode 100644
index 000000000000..0a4beeca472b
--- /dev/null
+++ b/app-i18n/anthy/anthy-9100h-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2003-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp-common
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/37536/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="emacs static-libs"
+
+BDEPEND="emacs? ( >=app-editors/emacs-23.1:* )"
+DEPEND=""
+RDEPEND="${BDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-anthy_context_t.patch" )
+DOCS=( AUTHORS ChangeLog DIARY NEWS README )
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ EMACS="$(usex emacs "${EMACS}")"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -type f -delete || die
+
+ rm doc/Makefile* || die
+ dodoc -r doc
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}