summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-19 22:52:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-19 22:58:26 -0400
commit9be10e73612456cded43ee76f513436f49bf65d0 (patch)
treedca2de4f9d9232aa9ef4c19c1831919a434b6208 /app-emulation
parentapp-emulation/ruffle: modernize cargo.eclass usage (diff)
downloadgentoo-9be10e73612456cded43ee76f513436f49bf65d0.tar.gz
gentoo-9be10e73612456cded43ee76f513436f49bf65d0.tar.bz2
gentoo-9be10e73612456cded43ee76f513436f49bf65d0.zip
app-emulation/ruffle: adjust workspace handling
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ruffle/ruffle-0_p20230525.ebuild12
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/app-emulation/ruffle/ruffle-0_p20230525.ebuild b/app-emulation/ruffle/ruffle-0_p20230525.ebuild
index 9b524bb27a10..437ae7c21095 100644
--- a/app-emulation/ruffle/ruffle-0_p20230525.ebuild
+++ b/app-emulation/ruffle/ruffle-0_p20230525.ebuild
@@ -587,12 +587,12 @@ src_configure() {
# see .cargo/cargo.toml, only needed if RUSTFLAGS is set by the user
[[ -v RUSTFLAGS ]] && RUSTFLAGS+=" --cfg=web_sys_unstable_apis"
- if use test; then
- # tests will be skipped if don't build everything
- cargo_src_configure --workspace
- else
- cargo_src_configure --package={ruffle_{desktop,scanner},exporter}
- fi
+ local workspaces=(
+ ruffle_{desktop,scanner}
+ exporter
+ $(usev test tests)
+ )
+ cargo_src_configure ${workspaces[*]/#/--package=}
}
src_test() {
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index dc60eb5bf290..e0410394da4a 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -68,12 +68,12 @@ src_configure() {
# see .cargo/cargo.toml, only needed if RUSTFLAGS is set by the user
[[ -v RUSTFLAGS ]] && RUSTFLAGS+=" --cfg=web_sys_unstable_apis"
- if use test; then
- # tests will be skipped if don't build everything
- cargo_src_configure --workspace
- else
- cargo_src_configure --package={ruffle_{desktop,scanner},exporter}
- fi
+ local workspaces=(
+ ruffle_{desktop,scanner}
+ exporter
+ $(usev test tests)
+ )
+ cargo_src_configure ${workspaces[*]/#/--package=}
}
src_test() {