summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-11-12 10:03:34 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-11-12 10:13:17 +0100
commit01b7538b5d54fa3ab367686158f4e6e573f7db55 (patch)
treea2a733cdffcdbe78c556a441c5c31b319e028451 /app-emulation
parentapp-emulation/free42: add 3.1.9 (diff)
downloadgentoo-01b7538b5d54fa3ab367686158f4e6e573f7db55.tar.gz
gentoo-01b7538b5d54fa3ab367686158f4e6e573f7db55.tar.bz2
gentoo-01b7538b5d54fa3ab367686158f4e6e573f7db55.zip
app-emulation/plus42: add 1.1.13
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/plus42/Manifest1
-rw-r--r--app-emulation/plus42/plus42-1.1.13.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-emulation/plus42/Manifest b/app-emulation/plus42/Manifest
index 8ac81516268d..015d901bfd47 100644
--- a/app-emulation/plus42/Manifest
+++ b/app-emulation/plus42/Manifest
@@ -1,2 +1,3 @@
DIST plus42-upstream-1.1.11.tgz 7613219 BLAKE2B edd390be71318fbe351e997e3cedb2bf145fea89ed39ac91726c712d1906a28860f515de5bb657d0447d496d7469c6c01b185f6396c9227e120cbb8ea078bca3 SHA512 082042319ee9f58fc6c3fe86e9b15d03e17ae6e3d30441df2e953d71fe670f8004ff25da8986fb6f89fd4f6823a473fbfa620560e6051aa2a3bfebd9fbbd67a2
DIST plus42-upstream-1.1.12.tgz 7613262 BLAKE2B 983388034eca0bfceb4d2ca129a7fad5192e642e6bb05365bb883b7cb9a7bc571181b28214c2d4a9efd97a87d2836f95e4755e33f7a98bcc8bba0b5a97e4f226 SHA512 b0502d3132e49fc29d3e5b6b9d9fe4d6de52ebf5a44937a3847932993563e7ba12cca72dfa6d505acaa5eb95ffd5692df4b10b35075e846a17a9a621f31df225
+DIST plus42-upstream-1.1.13.tgz 7613465 BLAKE2B 88940160f2d5aa9c06b9b19b12a4bc747ef7c9e354075ca144997cffda42f7a07f3da602385b9e574402fa957463dce4bf3ba1237c11fa34d99bb3ed36249a67 SHA512 ff1f80be13337debf98e1a3e157e4bd5f017acde27e716254496606af8b4ffd967f8a03dc4e263e6fdf4ec62acf46fd5981297c0b29748b7dc0320969b14fa5b
diff --git a/app-emulation/plus42/plus42-1.1.13.ebuild b/app-emulation/plus42/plus42-1.1.13.ebuild
new file mode 100644
index 000000000000..3916a804001b
--- /dev/null
+++ b/app-emulation/plus42/plus42-1.1.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PN}-upstream-${PV}"
+
+DESCRIPTION="An Enhanced HP-42S Calculator Simulator"
+HOMEPAGE="https://thomasokken.com/plus42/"
+SRC_URI="https://thomasokken.com/plus42/upstream/${MY_PV}.tgz"
+S=${WORKDIR}/${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa"
+
+DEPEND="app-accessibility/at-spi2-core
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CREDITS HISTORY README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-fix-makefile.patch"
+ "${FILESDIR}/${PN}-1.0.12-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
+ emake -C gtk clean
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
+}
+
+src_install() {
+ default
+ dobin gtk/plus42bin gtk/plus42dec
+}